No Google Play Store Key while update the patch obb


I build a patch version(1.1) of my game to update my released one(1.0) and upload it to google play. And I use google play to update my game on my phone. Then I got the No Google Play Store Key message.

But when I download version 1.0 and worked fine. There is no any obb not found or store key issue. Did I do anything wrong? (Distribution Signing in project settings are already been setting)

  1. Use Unreal Frontend to build a release version 1.0. (3rd person template project with one cube mesh)
  2. Upload both .apk and main obb file under the [Project Name]\Binaries\Android\ folder to google play.
  3. Download the game and run normally.
  4. Make some modify to my game. (Add another cube mesh)
  5. Use Unreal Frontend to generate a patch 1.1 based on release 1.0.
  6. Upload the new .apk under [Project Name]\Binaries\Android\ folder and the .pak under [Project Name]\Saved\StagedBuilds\Android_ETC1\TestPakWin2\Content\Paks\ folder as a patch expansion file(patch obb), but no modify the main obb(use the old one).
  7. Update the game by google play.
  8. Run the game and occur No Google Play Store Key issue.

Is anyone can give me some idea?

still no one can help me?

Hi wingedrobin,

I apologize for the delayed response. Are you still having trouble with this? Have you contacted Google Play to see if a key is correctly registered?

Hi Adam,

Thanks for your reply. Now I had already add a google play license key and the issue is gone. So, according to your reply, add a license key is the correct answer, right? I think this post can be closed, thanks! :slight_smile:

I believe that is the correct method to resolve the error. I am happy to hear you were able to resolve this and will mark this as answered for tracking purposes. If the Google Play error returns or persists, please post back here and I’ll be happy to take another look.