Download

No dynamic shadows if Static lighting is turned off?

Using 4.14, forward renderer for VR, but I think I ran into this problem earlier with the deferred renderer.

Basically, I think I’ll need to light my levels 100% dynamically because they will be randomly generated. Problem is, if I turn off static shadows either in project settings or with “Force No Precomputed Lighting” in World settings, as soon as the static lightmap data is flushed, all of my movable character actors stop casting shadows too!

It’s a simple outdoor scene (all actors, no terrain), with a single Stationary Directional Light. If I re-enable static shadows and build lighting, all of my dynamic shadows come back too. Shadow quality is set to Epic in settings. I’ve clicked and changed every setting I can find on my light and nothing brings my shadows back.

Any thoughts?

Sounds like this tip might work, but it’d require some element in the scene to have baked shadows at all times: TIP: How to Enable Dynamic Shadows & Correct Reflection Maps on Mobile - Android Development - Unreal Engine Forums

Thanks in advance - pulling my hair out over this one tonight!

Update - Still can’t get any shadows to render if the stationary directional light is set to not render static shadows. Using the tip from the above link looks like it works though - I have a simple static cube that I build lighting on and everything else in my level is set to stationary + no static shadows or movable. Feels like a strange hack though!

So, your dynamic shadowing successful?
I set up my project as the links your share, and got the right shadow when playing in the engine.
But no shadow&wrong light on device(package to android gearVR).
i’m using UE 4.14 Device:Samsung S6edge.

I’ve only tried this setup on PC, sorry!