Download

No *depth / IR* tracking in my project - 4.4.1, DK2 sdk 0.4.1

First post here!

I’ve set up a project based on the C++ FPS template and the Separate_View wiki page:

Things are working ok! I’ve set up my subclasses and compile clean. No stutter, and the head is tracking independently from the player character / movement.

Strange Thing though - I get no DK2 positional tracking. The IR camera’s blue light is on, and I get full rotational movement from the rift, but I think its all the fallback gyro rotation. I can’t lean in / lean out and see depth change.

If I start a new project based on Mitchell’s Rift First Person Template, tracking works fine.

Is there something I missed to enable DK2’s special brand of depth tracking? I’ve put some C++ code work into the player character, controller, etc and don’t want to have to start over with the other template since I’m new to Blueprint.

Thanks for any help or advice! Stoked to be a part of the UE4 community!

On some further digging, I found the hmd stats command - OK | Oculus

Mine says:
PoTR: ON
Vision: ACQ

And Vision goes to Lost if I move out of the tracking volume, so it looks like the camera is reading the hmd okay.

Also, manually turning this on in code doesn’t make a difference: GEngine->HMDDevice->EnablePositionalTracking(true);

edit

placing this in my PlayerController also doesn’t fix the issue: PlayerCameraManager->bFollowHmdOrientation = true;

edit 2

I just created a new FPSTemplate game and positional tracking does work there. So I’m guessing the Separate_View code is throwing something off? Anyone use the Spearate_View C++ code with DK2?

Thanks again!

I noticed the same thing after following the instructions on the Separate View wiki page. But it also happened on a fresh build of the FPS C++ template. Did you use the C++ or Blueprint FPS template when you had success?

In the spirit of “Don’t be as stupid as me”…

In my case the universal lack of positional tracking was due to not having the latest and greatest runtime and/or firmware installed on my testing machine. After updating both, the plain C++ FPS template worked fine.

On the other hand, the Separate View test only sort of worked. If I am facing in the direction where the floor text is readable, it works fine. Facing in the opposite direction, it works backwards. Up/down works fine regardless of facing direction.

So it looks like something in the Separate View code is using World coordinates rather than Camera coordinates. Will look at the code and post if/when I have a fix.

I’ve been away from my dev box for a few days, but when I get back, I’m going to grab latest everything and create my project from a new C++ FPS template. I had originally made my project in UE 4.3 and then updated it to UE 4.4, and I wonder if that transition did something fundamental. Will report back if/ when I fix it too :slight_smile: