No compiler was found, In order to use a c++ template, you must first install Xcode

Please help! I cannot use my Macbook pro as my development pc anymore.

What happened :

I was using UE4.18.3 for a few days. It was fine. I used CLion with plugins. It crashed (my C++ code try to access a null’s properties). After I restarted it, the compile button went missing. I cannot compile my existing project anymore. And when I tried to create a new project, it says as in my header.

My environment :

Macbook Pro 2017

What I have tried so far :

Uninstalling and reinstalling Xcode
Uninstalling 4.18.3 and reinstall 
Install 4.19.0 Preview 3
Install 4.17
Remove Epic Launcher and all UE and reinstall
Right click on .ulauncher and generate xcode project.

Please help! I really have no idea how to continue.

Thanks for any help you can provide


This also happened to me, on a Linux system. I think the error is in the CLionSourceCodeAccess plugin, because right after I installed and crashed, it broke my ue4 installation, and reinstalling does not help. Have you solved it?