No ambient occlusion in VR

So I have no visible ambient occlusion in projects created with the Virtual Reality template.
My screen is completely white in buffer visualization (Ambient occlusion).

I tried:

  • adding post processing volumes with the ambient occlusion cranked up
  • going to project settings → rendering → enabled ambient occlusion & ambient occlusion static fraction
  • export project setting from another project with AO working (for example the First person shooter template) and importing it into my virtual reality project
  • baking my light with and without light reflection capture (which shouldn’t make a difference, but who knows)

Also I’m using version 4.13.1 and I have the same problem on different PC’s in different projects all created with the VR template

That’s strange, I know that AO is heavy for VR and is disabled by default, but I don’t know why it is not working after enabling it manually in the postprocess effect. Try setting the post process volume to unbound?

No, doesn’t work :confused:
Also tried setting AO to true in the .ini files and using a command line in the console to enable it. But nothing worked.

You can check out this thread No ambient occlusion in VR!? (Virtual reality teplate project) - Rendering - Unreal Engine Forums

no, it’s a long time ago, but i know it was turned off in some text file from the project.
So if you dig deep you can actually turn it on again if you want to dig in the code.
But be careful because i know my project crashed when I did that so maybe it’s turned off for a good reason. Maybe they already updated it since then, don’t know :s sorry man.

Did you find the answer to this? Im trying to get a nicely lit environment with Static Skylight and Stationary Directional light as suggested by a lot of people, problem is that it looks very flat, especially in areas (indoor) where there are primarely indirect light, so i thought i could soften it up with baked AO… but no matter what i’ve done so far, i get the same white screen as you. I’ve searched for some good examples, and people that has it working, has showed results, but not how they got to those results. So im hoping someone would be so kind to post a working project which show how to set it up properly.

hmm, so if i understand you correct, you had to make an engine ini change in order for these settings to have any effect?

all of this commands enabled ?

yes correct, I turned it on everywhere i could. So project setting etc etc but since that didn’t do anything I went into some text file (the .ini that was probably) and turned it on in that as well.
Let me know if it worked for you. I know it caused some crashes with me so I just turned it off again :confused:

jup and if i remember correctly, it didn’t work for me if i did it with a command. I really had to change it manually in some files

just check what is exactly off

Are you using forward rendering? If so, AO is not supported.

pfff sorry really can’t remember if we used forward or deferred. My best gues is forward so that could explain the crash as well when i forced the AO on