No ambient occlusion in VR template ?!

I already posted this thread in the rendering part of this forum, but it seems appropriate to also post it here.

So I have no visible ambient occlusion in projects created with the Virtual Reality template.
My screen is completely white in buffer visualization (Ambient occlusion).

I tried:

  • adding post processing volumes with the ambient occlusion cranked up
  • going to project settings -> rendering -> enabled ambient occlusion & ambient occlusion static fraction
  • export project setting from another project with AO working (for example the First person shooter template) and importing it into my virtual reality project
  • baking my light with and without light reflection capture (which shouldn’t make a difference, but who knows)
  • set the AO in the .ini to true and also checked for other possible options -> restarted the project
  • I tried to enter this line in the console and this is the result in the output log:
    Cmd: r.DefaultFeature.AmbientOcclusion 1
    r.DefaultFeature.AmbientOcclusion = “1”
    LogMaterial: Missing cached shader map for material DebugMeshMaterialFakeLight, compiling.

Also I’m using version 4.13.1 and I have the same problem on different PC’s in different projects all created with the VR template
Any help is appreciated

SSAO is expensive in VR, I would suggest you avoid it if possible.

Well, the scene is quite minimal so UE4 would be able to handle it.
So any sugestions on enabling the AO are very welcome :slight_smile:
i’m suspecting it’s disabled in some blueprint or piece of code maybe?

EDIT : NVM overlooked that you already done what I suggested in the original post

Look in the DefaultEngine.ini file of the project.
Any Ambient Occlusion CVar in there will override project settings. It’s really handy for putting in your own CVars for quality settings but sometimes settings are forgotten about in there and you don’t know why you can’t change them in the editor.

It’s in Config\DefaultScalability.ini
I bravely removed the file from my project, worked great, got SSAO again. If you’re not as brave, modify the file to your liking.

Ah thanks man!
Modified the DefaultScalability.ini and it worked :smiley:

Woot Thank you so very much for this. Saved me too.