Niagara particles.SpriteSize not working

I must admit that I’m confused, the tutorial shows the sprite size is supposed to be there by default, which it’s not and when I added it, instead of a minimum, maximum value I had to enter, it was a direct x and y size. In addition to that, no matter what I entered, it did not affect the sprite size.

I am missing something or is there something wrong with my version of Niagara, I doubt it would have gone unnoticed.

Thank you

I found the answer to this:
"To set this up, Click the carat next to the Particls.SpriteSize variable and search for “Vector 2D from float”. This will take away your two size option boxes and replace it with one. Next, Hit the newly created carat under the Value tab and search for “Uniform Ranged Float”, now you can set the minimum and maximum values for the sprite size, using the minimum and maximum values.

Once you have all the modules set up for particle spawn you can go ahead and fill out the values using the settings I have here, or play around to find settings that you prefer, then we will dive into the modules in the Particle Update sections."

It also might be due to the fact that you have a Calculate Size By Mass module in your emitter.