Download

Niagara particles flickering in latest .26 release

Currently a simple sprite emitter with fixed bounds size flickers as if from occlusion when 1 or 2 particles overlap.
Transparent particles. Custom descending sorting.

Same exact Emitter+System doesn’t flicker in .25

Updating this since it’s an issue on the Released engine version.

For anyone experiencing the issue, if you cange the emitter properties Sim Target from GPUCompute Sim to CPUSim the issue is solved.

It appears that GPU sim is not taking Fixed bounds into account.

Hello
I confirm flickering bug from GPUCompute Sim .26

Heya, can confirm I’m running into this issue as well. Having to run my smoke effect on CPU for the time being.

Hey folks,

Has anyone had the chance tosubmit this as a bug?

twice. Never got a reply in either case.

I’ve had a look through the current Niagara related issues, and it appears that both closely related ‘flickering’ issues are backlogged. We’ll ping the team about it to see. :slight_smile:

Great.
Been waiting for a fix to get the vector field system to finally work off the cpu :slight_smile:
Makes little difference in the end, but anything to reduce the ms count helps.

4.26.1 Niagara GPU particles are flickering on Scene Capture scene, not sure why.

I submitted a bug report just now with a project and a youtube video. (Case # 00309981)
I am not sure if it’s identical to the issue OP has, but it’s been rather annoying, and alongside my OCD this results in not being able to proceed with the package I want to update as it actually stresses me out hehe.

Could be a similar issue.
Honestly haven’t even bothered to try using cascade for it. Or for anything at all in probably the last 6 months.

Easy to check though. Set the lifetime of the sprite to infinite, up the spawn rate so you are sure that sprites overlap, and if the whole thing starts flickering and giving you epilepsy that’s it…

In my case, the particle is running as a component of a Vector Field render target…
The end end result is stuff like tessellated show that shapes and recovers magically at a rate of about .02 sec or less. Very fetching.
Or trampled grass that actively looks as if wind is pushing it up and down, or as if ants were having an orgy I guess.

Fortunately I found the CPU workaround, or by now I’d have died from a seizure…

I really wish they could fix this soon - any ideas on what I could try to turn off and how (e.g. occlusion) to keep it on GPU sim and remove the flickering. I am using 75,000 particles for a visualisation and have a RTX 3090 card to make it work so I really want to keep it on GPU

Same Problem here. Should be fixed that for Gpu simulation.

My particle system is constantly flickering in preview and during sequence renders :frowning:
Also is half opacity when testing in game. Would love to get this flickering fixed!

1 Like

Has this ever been resolved? I’m still having the same issuein multiple versions of UE4

Just wanted to chime in and say what helped for me was reducing my particle emitter sphere radius under the Sphere Location function(?) in the Particle Spawn manager. If the radius is over a few thousand I will start to see rapid flickering on the small particles but if the radius is below 500 I don’t see the flickering as much.

Another important property that will help with this is camera culling. Go to your Sprite Renderer settings and enable Camera Distance Culling under the Visibility section. Play around with the max camera distance, something under 500 works for me if I am dealing with a particle system attached to the player.

¯\__(ツ)_/¯

CPU workaround is only good for me up to 500 particles :frowning:

This is still an issue months later, nobody seems to know how to fix it!

EDIT: After some quick experimentation, it seems that if you increase the bounds of your gpu sim (which may or may not be an option for you) the flickering largely goes away.

try to set the Sort Mode to View Depth in Sprite Renderer?

1 Like