Download

Niagara particle rendering issue on Quest 2

Hi,

I am noticing some unwanted rendering issues of Niagara particles in VR and when building to the Quest 2. I am using UE 4.26.

I have a simple scene with some particles, a ground plane, a point light and the default VRPawn.

When I build and play, the particles seem to render properly when I look directly at them, but if I turn my head to one side or the other, they pop off, or render only in one eye. You can see the render glitches in the video below as I turn my head away from the particles. Notice the asymmetrical rendering in left and right eyes.

What is causing these render issues? How do I solve it? Can I expect more reliable rendering when using Cascade?

Hmm… I’m developing for Quest 2 also and Niagara seems to be working fine for me. I had a similar issue in a PC project last year that turned out to be a culling/bounds setting somewhere. I can’t remember the exact fix but essentially the particles were outside of the bounding volume, so when it was no longer in view of the camera (left/right eye) the emitter was culled. Sorry I couldn’t be more help. Try searching forums for a Niagara specific issue, rather than mobile/vr and you might find more info. I’ll update if I find the setting. :slight_smile:

Thanks @Mr_Jekyll_88 . I just tried doing a test using a Niagara emitter from the UE content examples and was able to get it working. It may very well be something having to do with the bounding volume.