Niagara Fluids volumetric translucent shadows are "backwards"

I love the new Niagara Fluids plugin, but I’ve noticed an odd bug: when I try to illuminate a 3D gas system, the shadows are rendered “backwards”. I’m attaching a video showing the problem. The fluid sim is clearly casting a shadow, but it appears as though a bug somewhere has flipped the sign of a vector, because the shadow isn’t properly positioned, and seems to move in the opposite way as the camera.

The problem happens with directional lights, spot lights, point lights, and rect lights.

Details: Tested using UE 5.0.0. The bug is present on both Windows and Linux. To reproduce, start with the default scene. Simply instantiate one of the default 3D NiagaraFluids templates (I showed the “Grid 3D Moving Grid Fire”, but any will do) and illuminate it with a directional light. Make sure “Cast Shadow” and “Volumetric Translucent Shadow” are checked on the fluid sim, and make sure “Cast Dynamic Shadows” and “Cast Translucent Shadows” are both checked on the light.

This bug does not seem to be present with the 2D fluid sims.

Any thoughts on how to fix this?

IM having same issue as this right now, any word on how to fix?

1 Like

Unfortunately, I never found a resolution to this. I imagine it will be fixed eventually…

1 Like

Having this issue using cloth with (thin) translucent material, will like to know how to fix it.

Hey everyone,

If you have encountered a bug in the Engine, please also report it through our bug reporting process- Report a Bug - Unreal Engine. This will help us identify the bug more efficiently, get it in front of the right team, and help others in the community find this issue.


In Unreal 5.1, I am not getting any shadow of the 3D Volumetric Fire even though all the necessary cast shadows options are on. Not sure if this is a bug in this version or not.

Is anyone facing the same issue?

1 Like

Same here, i can get a shadow from the entire bounding box but not from the contents

1 Like