Niagara Fluids Not Activating

Hello there,

I am a bit embarassed, I am very eager to explore Niagara Fluids but it doesn’t seem to want to start on my computer.

Steps:

  • Activated Niagara Fluids plugin
  • Restarted UE5
  • Created new Niagara System
  • Selected “New system from a template or behavior example”
  • Chose any 3D gas fluid
  • Saved Niagara System
  • Drag and drop the Niagara System in a basic empty map
  • Verified that the Niagara System auto activate

Result:

  • The niagara system appears in the scene but does not activate
  • When running the game, same thing, the niagara system does not activate/play
  • When editing the niagara system, same thing, the gas/fluid does not play

Here is a screenshot:

My Graphic Card is an Nvidia 1080 running with 512.95 drivers.
Engine Version: 5.0.2-20280985+++UE5+Release-5.0
I could not find what are the minimum requirements to run Niagara Fluids.

I am a bit clueless on what to do, any idea?
Thanks for your time.

Some Fluids work such as the 3d wateror the 3d grid gas explosion.
However, fluids like Grid 3D Gas Dust Explosion or Grid 3D Gas Simple Particle source does not compile.

There is the error from Niagara Editor log:

It is stated that the Mesh distance field generatioon is not enabled.
It wasn’t, so I turned it on and restarted the Engine, but the error persist.

I tried to turn on the “Allow Distance Fields (Experimental)” in the plugin section, still no luck.

I will keep this post updated until I find the answer.

After activating Lumen in the project settings all Niagara Fluids are working.

Project Settings > Engine - Rendering > Global Illumination > Set: Dynamic Global Illumination Method to Lumen

2 Likes

for me not yet working! Anybody the same?

For me not yet working either!
It is stated that the Mesh distance field generation is not enabled. But it was.
Dynamic Global Illumination Method was Lumen.
It just doesn’t work.
I tried it on another computer and it works well.