Niagara DOF with translucent material

Hi everyone :slight_smile:

It’s common knowledge that Unreal cannot render DOF for translucent object correctly. Because translucent material does not write into SceneDepth Buffer.

The only working solution I encounter is to use a copy of the mesh with an opaque material on it, which is not rendered in the main pass, but write in the SceneDepth.

The issue with Niagara is that the only way to disable the main pass is to select the Niagara System Component once in the scene, and disable “Render in Main Pass”.
So to create the apply the trick explained above, we have to duplicate the hole Niagara System, which double the performance cost :confused:

Could it be possible to tell the Developers to add the options for “Rendering in Main Pass” in the Modules : Mesh Renderer and Spirte Render ?

Do you have any better idea ?

Hi! Just discovered this case, did you try unchecking the case “render after DOF” in the translucent material?