Download

Newly created scalar parameter doesn't show any effect when changed in Material Instance

Hello everybody,

Currently I am trying to change a material by adding a new scalar parameter which allows me to fade in / out the material via Blueprints.
So, I’ve added a new parameter called “cOpacity” into the parent material and added a subtract node in order to manipulate the opacity of the material.
a143356aa6df13dd23cd1980b18cf054584e32fb.png

Inside the editor for the parent material, changing the value of cOpacity works perfect fine and shows the wanted result of having 0 = visible and 3 = invisible.

In a material instance of this material changing the value of cOpacity shows no effect.

4faa9227de2cb0096c4bdeda791add99b52ae119.jpeg
d35d8e76d44b473491b6a83b884880c56a040f95.jpeg

Trying to change the value via BP does not show any effect too.

I already did this for a different project last year (which I no longer have) and I’m pretty sure that it should work just like that.
Interestingly other parameters show a change when changed.

Is this a bug in 4.15? Could the material (which is from a marketplace asset) be from an older version and that’s why the existing parameters are working fine and the bug only exists with newly created parameters?
Any help is appreaciated. :slight_smile:

Sincerely,
Kia.

Don’t subtract, Multiply it.

Yup, as above. Pretty rare you ever need to subtract anything.

Plus, negative numbers going into some material params cause wierd artefacts.

Changed it to multiply, works fine on the parent, but on the instance material it either gets fully invisible at 0.0 or fully visible at anything greater than 0.0.

I just don’t understand why it works on the parent, but not on the instance. :confused:

Oddly enough it appears his Mat instance was bugged.

Yep.

I tried a different pre-existing material instance and changed the parent to a duplicate of the original material which has the cOpacity parameter added, then it worked.