Download

[Newcomers Readme!] How To Install UE4 From The Launcher

Welcome all newcomers! I sense there are going to be a lot of new faces around here this week :slight_smile:

I’m noticing a few of those who have never used UE4 before aren’t used to the cool launcher yet, so if you haven’t got the engine installed - this is the thread for you! Make sure you grab and install the launcher (big blue button at the top right of this page ;)), and then you can get started. Here’s a quick and dirty guide for getting the engine installed via the Launcher so you can jump right in.

Navigate to the ‘Library’ tab
- This is where all of your projects, your downloaded Marketplace content and Engine Installations can be managed and installed.

da455bca6028c262490cd4aab766ae05786c5578.jpeg

Click on ‘Add Versions’ in the ‘Engine Versions’ category
- You can have multiple versions of the engine installed at each time, just click the Add Versions button to create a new Engine slot, and select the version you want to install.

Select an Engine Version in the new Engine Slot, and hit install!
- In a few short minutes you’ll be ready to make awesome games!

While you wait for the engine to install, you can check out some of the following awesome links that’ll give you a good head start!

Official Tutorial Videos
Official Documentation
Official Community Wiki

Enjoy! :smiley:

How about making this sticky in General section?

I’ve stickied this for the moment and left it in original in Content Creation. Definitely a helpful thread to link to at the moment. :slight_smile:

I tried to get an answer in the “General Discussion”, but wituout success.
So, I try it here again:

My working machines (Win64) are not/never connected to the internet.
Therefore I’ve a seperate Linux computer.

So, what should I do to install UE4 on my offline Windows working computers ?
Perhaps there is a possibility to transfer UE4 from another Windows computer that is connected to the internet ?

Thank you in advance !
Tompov

Hi Tompov, in this situation you’d probably be better off getting the GitHub version of the engine, downloading all the files and then copying the directory across to the other system. You can download the pre-compiled engine through the launcher and then copy them across, but that’s a long-winded process and you might still be missing a lot of required distributable’s.

In all honesty though, you’ll no doubt regularly want internet access while using the engine (especially as a new user), so I would recommend using an internet connection on the Windows system if you plan to develop on those.

You can find the Pre-compiled engine installs in the same install location as the launcher.

OK, thank you very much for the clearing words !
So I’ll try the GitHub version - or buy a new UE4only-machine :wink:

Tompov

Thanks for this, it is very helpful :slight_smile:

Thanks, :slight_smile:

after downloading 4.7.1 yesterday around (4 GB) it appears there is an update to 4.7.2 so i pressed update to find it will download another (4 GB) so i pressed pause then cancel the update and now im stuck with 4.7.2 which need to download another 4GB from the start and cant go back to 4.7.1 so i removed it ,lucky i have backed up the engine folder named “4.7” (11 GB) which contain the installed engine , plz help , how can i make the launcher realize the engine is there in the folder , my internet download speed is 120 kb/s so it would be hell for me to re-download again

update:
it can verify the files if is the right version is selected
bad thing 4.7.1 selection disappeared and replaced with 4.7.2 :frowning:

Hello guys, I am stuck in a “please wait” message, please see screenshot:


Edit:
My connection is slow atm (384kbit/s), but I let it in the above state overnight, and ProcessHacker stated that just ~20MB was downloaded in that time.
Edit2:
I am on Windows7.

Edit3:
after signing out, and re-entering password, it gave me the option to click “install” in the yellow outlined box! Let’s see how it goes from here.
Edit4:
it finally started now, I read the hint that some restarting helps, but I feel like signing out so you need to re-enter password, was important too - so I let this standing here, in case someone else has similar trouble.

Guys I need HELP!!!

I visited youtube and saw a video on gamespot channel.I saw the title: UE4 is free! I went to the unreal engine 4 page and downloaded the launcher. i didn’t have time to download it until today. Today I opened the file and it started downloading: 2 secs later an error popped up: ,This installation package is not supported by this processor type. Contact your product vendor.’’

PLS HELP I WANT THIS ENGINE NOW IT’S FREE!!!

@CrazyMuchaco - You need to post your system specs so we can help, what CPU do you have?

Hello! I have a bit of a stupid question but what the hell… When i want to install engine from the “Epic Games Launcher” it’s by default installed in “Local Disc C:” where i don’t seem to have enough space (i have over 13GB free in there)… How do i change the installation directory so it can be installed in “D:”???
PS: Thank you so much in advance, i’m actually a hard newbie so any help would be much appreciated… Thanks!

Hey KappoDB, try installing the Launcher itself to a different drive. By default the engine slots install to the same directory.

As a first-time user, it might be important to note some quirks of the launcher - thankfully I only had to spend a few minutes finding the right place. Since I have a second storage drive I wasn’t sure initially where I wanted to install, and quit the launcher and needed to re-open it. Once I found the launcher applications, I wasn’t sure which one to use (either the EG launcher or the UE launcher). I tried the Unreal Engine launcher first and got the persistent “Please Wait…” message in the version installer widget that I’m sure has baffled others - from what I can tell, the UE can only be downloaded through the Epic Games launcher, since as soon as I brought up the Library tab, the “Install” button was usable.

The installation path can also be a little tricky to blindly stumble through - default path (for Windows 8 64-bit, anyway) is – *C:\Program Files\Epic Games\Launcher\Engine\Binaries\Win64* – There are only the two launcher applications in this folder, and a couple of other applications that I have no idea as to the use of, but that last bit doesn’t surprise me as I have zero clue what I’m doing with this engine. I barely have a handle on Maya, given my mid-completed 3D Animation education, but I’m excited to see what I can make happen with Unreal.

Hello. New to forums. After downloading the files from the launcher, can I copy these files to another pc? I don’t want to download again the same files to my laptop. Thanks.

Well I’m came here with little bit different problem about loading map of kismet jazz jackrabbit 3D reboot.

I think you use UDK? -> make sure to post your problem into the udk forum: UDK - Epic Games Forums To solve your problem you have to click on the main root of your content browser - fully load - now it should work :slight_smile:

Can’t Load EULA - Can’t download Engine

I’ve got a 768k DSL line but routinely average 2/3’s of the top speed as I live in a (seriously) underserved area of Alaska

Just downloaded the (93mb) Launcher/Installer and when I run I get the small window stating ‘Please Wait…’ for abut 3-5m before the launcher opens up…

Six tries now, I keep getting the same problem, a simple text message on a large white screen: “ELUA Error - An error has occurred while loading the End users License Agreement. Please contact our support team.”

While I am aware I certainly don’t have a fast connection (on a good day about 300MB/hr)…I’m just slow, and my ping is usually in the 20-50ms range…is this a launcher problem or is the downloading of the EULA getting pushed aside by all the other downloads happening…took nearly 10m for all the nice pictures to load…which is nice, but don’t want every time I launch the thing.

First time I ran the launcher, the button was yellow and for me to download the engine. Since then all I’m getting in the same spot is a graying boc that says “Not Installed - Unreal Engine Preview” - and when I go to the Library - it’s offering “4/8/0 Preview 1 Install” (But can’t install because of the same EULA error.

Help please…and while it sounds cliché and is probably the same for many folks here…I have a dream…and that’s making my own game no matter how many months/years it takes, even if I’m the only one that ever enjoys it.

Thank you

PS…after searching I dumped the Torque3D I’d downloaded as this platform looked much better with even better support and available assets - so really looking forward to diving in (deep end first of course)

Make sure to post this on answerhub -> https://answers.unrealengine.com/ :slight_smile:
Also make sure to take a look at this thread: I couldn't install UE 4.7.6 through epic game launcher - UE4 AnswerHub