New water system doesn't render?

Hello, so I tried updating to 4.26 to use the new water system. I enabled the water plugin, and enabled edit layers on my landscape.

You should be good to go at that point right?
However, the water material doesn’t render at all and is completely invisible, is there anything else I am missing for using it when upgrading from an older version?

I’m not sure because I never used new water system in 4.26 version (I still working on 4.25) but I really recommend watch the latest life-stream by Unreal Engine Devs about water system.
Link here - UnrealEngine - Twitch (2 months ago)

In my case I use animated water material that I already get from marketplace and it work pretty well.

guess its a bug same here

Don’t mean to res a one month old thread, but I’ve read that you need to enable edit layers on your landscape BEFORE you add the landscape. Meaning, no landscape should be in the map, click on Modes, select Landscape, BEFORE adding the new landscape, select the checkbox for Enable Edit Layers, and then ADD the landscape. Then add your water body. The problem with this method so far is that it just plain sucks for people wanting to add the new water systems to their existing maps.

Ah, that might put a kink in my plans, I already have a detailed landscape in my map and was hoping to implement this system in my existing map.

Can anyone else confirm this?

I was trying to add the new water system to my existing map… everything displays perfectly in the editor. No water shows on play though. I’m wondering if this is to do with it being an existing landscape?

Best regards,

Can’t thank you enough my friend. I searched a lot to get a solution to this weird problem and your solution worked like a charm. So happy to finally see some water on my landscape. :cool:

Hey guys. I was also having an issue with water not rendering on an existing landscape. I think one of the tips mentioned was moving the landscape to the 0,0,0 location but I think I found another way. When I put down a water body in my level, there is a “Water Mesh Actor” that shows up in the Outliner. For me, this actor was at the point 0,0,0 (hence the tip to move the landscape), but instead just move that actor to the same location your water body is at and it should achieve the same thing.


Thanks! That worked a charm!