New to Unreal; planes become invisible when viewing from opposite side

Hi there,

I’m new to Unreal so maybe it’s obvious but idk! Filepath for plane shape is: StarterContent > Shapes > Shape_Plane.

I’m using these as my road/buildings/etc. For buildings, I build from the outside in, so when time comes to look at the wall from the inside, it’s like a Klingon cloaking device was installed on it (aka invisible, but directional sliding grabbers still register that it’s there).

I also just discovered that there seems to be a set side where it appears to be solid, so even if I turn it sideways, one side will be solid and the other invisible (i.e., not just inside to outside view).

Why does this happen and how do I make it so I can see these planes from the inside?

Screenshots attached. Angled for better perspective.

Thank you for your time!

Planes, having no depth, are almost always considered to be one sided, as they aren’t really a solid shape.

For what you are doing, you will likely be better off with a thin cube (giving you 6 effective planes on one object), as planes rarely look right unless backed by other geometry.

If you want to stick with planes for whatever reason, Go into the material that is on your plane and click the ‘Two Sided’ option, which will tell the renderer that you’d like this plane to render both sides.e7ea41d14dd6626674a16463f003c21baa42b516.png

Hope this helps!

jwainwright answers this perfectly, but I figured I’d add why this happens. It’s refered to as ‘backface culling’, and happens because… well, lets say you have a cube. you can only see one side of the cube at a time, right? (or at most, 3 sides, but that’s being nit-picky). So the engine ‘culls’ the faces that are pointing backwards (hence the name ‘backface culling’) to save on memory and compute time. So your planes can be seen from their front but not behind because the engine is trying to optimize performance and isn’t drawing faces that are pointing the wrong way. jwainwright makes the point that you can tell the material to render the backfaces of the plane in the settings by ticking ‘two-sided’.

Thank you so much!! This is perfect! The reason I’ve been using planes is because they’re the thinnest material and I’m trying to use as little resources as possible. I’ve got a decent machine but definitely want to conserve as much as I can.

I’ll definitely consider cubes for buildings that are just for viewing, not for going inside.

Ooh I see! Thank you for that explanation! It helps to understand why it does that. That definitely makes sense when just viewing or walking around an environment, but it makes building frustrating and difficult to tell if edges are matching up correctly etc.