New Install New Project Fails to Build

New to UE and UE 4.9.

Installed and tried to create my first project. The project will not build I am getting the following error.

1>------ Skipped Build: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------
1>Project not selected to build for this solution configuration 
2>------ Build started: Project: MyProject4, Configuration: Development_Editor x64 ------
2>  Performing 5 actions (4 in parallel)
2>  PCH.MyProject4.h.cpp
2>c:\program files\epic games\4.9\engine\source\runtime\core\public\Windows/WindowsPlatformProcess.h(8): fatal error C1083: Cannot open include file: 'tlhelp32.h': No such file or directory
2>  -------- End Detailed Actions Stats -----------------------------------------------------------
2>ERROR : UBT error : Failed to produce item: D:\Dev\Clones\unreal_tutorials\MyProject4\Binaries\Win64\UE4Editor-MyProject4.dll
2>  Total build time: 2.52 seconds
2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ""C:\Program Files\Epic Games\4.9\Engine\Build\BatchFiles\Build.bat" MyProject4Editor Win64 Development "D:\Dev\Clones\unreal_tutorials\MyProject4\MyProject4.uproject" -rocket" exited with code -1.

I can find the file mentioned here:

c:\program files\epic games\4.9\engine\source\runtime\core\public\Windows/WindowsPlatformProcess.h(8): fatal error C1083: Cannot open include file: 'tlhelp32.h': No such file or directory

Has anyone run into this when creating a new project? It seems like something is wrong with the install.

I have VS2013 Community installed
I tried to install the windows 8.1 SDK.
I tried to uninstall and reinstall unreal. Still no luck.

Environment:
windows 10
VS2013 installed
Windows 8.1 SDK installed

Thank you in advance for any help.

Edit 9/13/2015

Current Work Around

I was hoping to get the project generation working without having to modify the includes, but this is the only way I have gotten it to work so far.

I added the following to my includes

C:\Program Files (x86)\Windows Kits*8.0*\Include\um

and

C:\Program Files (x86)\Windows Kits\8.0\Lib\Win8\um\x64\

so that I can build the project.

New issues
Now when I attempt to launch the project I get the error again for the missing tlhelp32.h file.

Hey Raand-

If you’ve already tried installing the Windows 8.1 SDK then I would suggest trying to restart the computer first. Also make sure that the file file exists in the file path C:\Program Files (x86)\Windows Kits\8.1\Include\um which is where the compiler is looking. If you’re still unable to compile a project then you may want to try reinstalling the SDK / Visual Studio.

Cheers

Doug Wilson

Hello and thank you for the help.

I am trying this and still getting the same error. I am trying one more time to uninstall everything and reinstall it.

I found the file in
C:\Program Files (x86)\Windows Kits*8.0*\Include\um
not 8.1\include\um

I am not sure why it is missing.

After reinstall of everything I am still getting the same error. I seem the file in that 8.0 directory still.

How can I find where VS2013 and UE are looking for the file?

I was able to find the path that VS2013 is using and it is the 8.1 directory as expected… I will try tomorrow to reinstall the 8.1 SDK

C:\Program Files (x86)\Microsoft Visual Studio 12.0>echo %WindowsSdkDir%
C:\Program Files (x86)\Windows Kits\8.1\

I am still having the same issue. I reinstalled the 8.1 SDK and tlhelp32.h is still not in the directory it expects it to be in, under the 8.1 Windows Kit.

Any suggestions on where to go from here would be appreciated.

Hey Raand-

There are a few things I’d like to verify to help me identify your issue. Are you using the binary version of the editor from the Launcher or are you using a source version from GitHub? When building the project are you using Development Editor and Win64 as your solution configuration and solution platform, respectively?

Additionally, are you using Windows 8 or Windows 10? If you’re using Windows 10 you will need to get the Windows 10 SDK.

Installing the Windows 10 SDK did the trick.

Thank you so much for the help