New Code Folders in the Editor

**EDIT: It was an error elsewhere. Sorry. **

And sorry, Unreal Engine 4, for doubting you. I still love you.

I can’t find a working answer to this problem, which is odd because it seems like it’d be a pretty glaring issue. Maybe its just me messing up.

I tried creating code (a class called “FolderProblemActor”) with Unreal Engine under a new folder (“Source[ProjectName]\DifferentFolder”) for organization:

Unreal Engine 4.7.2, however, won’t play along. When I clicked Create Class, it gave me this:

The code files were indeed created, and the folder was made, and Visual Studio was very politely informed of this - all by UE4. Unreal Engine seems to have forgotten that it just made the files and folder; consequently, it will not recognize the folder nor the files. Instead, it says that it had an error.

If Unreal Engine doesn’t recognize the code files, then I can’t do programmy stuff. If I can’t do programmy stuff, then Unreal Engine is essentially bricked.

I have closed and reopened both UE4 and VS. I have regenerated the source code from the .uproject file. I have tried yelling in frustration. None of those worked. Do any of you have suggestions so this problem can be swept away, and I can get back to enjoying the remarkable (and now free! Hurrah!) game engine?

It’s a poorly worded error. It hasn’t actually failed to add the new class, but it has failed to recompile and hot-reload your game module afterwards (which is why the class doesn’t appear in the Content Browser).

Does the Output Log (File → Developer Tools → Output Log) show any more details about why this failed?

Are you able to build your game module normally via Visual Studio?

Nevermind. It was the InteractableActor error. My bad

Output Log gave me this:

Too big to paste here, so [here][2] it is in a .txt file:

And I can still build in VS, but UE4 still doesn’t respond. Also, that error about the InteractableActor and whatnot does not arrive when I compile normally - neither in VS or UE4.

So to clarify, was that a genuine linker error that you have now fixed, or are you still having a problem when adding new classes via a hot-reload in the editor?

It was entirely faulty code on my end. It now recognizes folders and works beautifully.