Download

Neutral Lighting/Soften Shadows

Hey Everyone, I’d like to know how to create Neutral lighting in my scene. I’m going for a Hand-painted Scene at night. I want shadows and specular (no flat lighting).

At the moment, things are either too bright or too dark. I notice shadows are super dark and not rendering in areas (grass). Some shadows remain black even with a strong SkyLight and a bright Environment Color.

Apparently, the Environment color is not working- neither preview nor baked result. I’m unsure if this is related to the Auto Exposure (adjusted in PostProcess and WorldSettings)
Everything is light mapped and has the correct lightmap resolution. I also have a LightmassImportance.

The terrain doesn’t appear to be picking up some shadows either. It registers some rocks but not the lanterns or grass.

Any advice on getting this working? I currently have two lights: 1 Directional (Value 3; White); 1 Skylight (Value 300; Blue); 5 Points (Value 5000; Red)
PostProcess: Auto Exposure: Min/Max Brightness = 1.0; Exposure Bias = 0.0;
World Settings: Environment Color = White; Environment Intensity = 1.0

I might be missing something. Any ideas?

mgLXkYc.jpg

If you look at well lit night scenes in games or movies you’ll noticed that they are the opposite of neutral or soft. One of the best ways to create a readable but still dark looking environment is to use little ambient lighting and instead rely on a strong pale blue rim light to emphasize the silhouettes in your scene. You have a huge moon-like thing in your skybox that would be a great source for this light. To contrast this pale light and to make sure the dark side of your building is clear you can use the windows as strong but very local sources of warm lighting.

Anyway, that’s my artistic recommendation. On a technical level you should probably not use environment color at all. It is basically a deprecated feature that is no longer needed when using a skylight. If you do intent to use it though, you are probably blocking its light with your skybox. Make sure all background objects have shadow casting disabled.

The same thing is probably happening to your directional light as a white directional with that intensity and those exposure settings should be almost as bright as the sun and cast clear shadows. So my guess is the only effect you are seeing is from the skylight. Which also has a very high multiplier for normal use cases. The skylight captures your scene background and bases it’s illumination on that, so if you do have sufficient bright and self illuminating surfaces in you sky you might need such an extreme multiplier. Adding some slight blue haze to the background might be enough to both be picked up by the skylight and provide another source for interesting dark silhouettes against a slightly brighter sky.

Another advice is to never use pure colors.(nothing is pitch black, pure white, fully red etc) They are dull and look unnatural.
Look here what are normal values for day scene. https://www.unrealengine.com/blog/updated-lighting-in-templates
Night is a lot darker than day so you need to use quite low values. You also need to crank up the exposure to compensate dark enviroment. This way all post process effects like bloom and lens flares behave naturally.

Update

Thanks for the response. I believe I’m beginning to understand things better.

So the Skylight color and primary skybox color should be the same, correct?
The intensity is just something I have to eyeball.

Exposure is the overall brightness and darkness- and depending on the scenario it’ll have a different value. For night, it’ll need to be higher for readability (Exposure Bias: Value 1-3). The higher- the brighter and more bloom.
That’s my current understanding.

I’ve included the settings to try and help illustrate what I’m doing.

Baked.jpg

If I wanted something like this, how would I go about lighting it? Things are toned down but still visible.
8bbe4e963b354bdfe96e2ca01db2fdef3455ac31.jpeg

You don’t need to tint skylight. Skylights get’s its color from the actual skybox and color option is there to tint that even more. I just usually leave it as white.

Keep in mind that the overall mood of a scene is also strongly dependent on textures. It looks like you have quite a bit of contrast in your textures (very light rocks, dark trees, light walls vs. dark wood on the building, etc.) which will work against you if you’re going for a soft moody scene. As a general rule, the stronger your main shadow-casting light is, the less impact textures will have, and vice versa. For example on an overcast day, there’s no contrast between light and shadow, so most of what you see is the “texture” of objects.

If you’re trying to compare overall lighting it can help to look at screenshots in black and white. Here’s your scene compared to that reference scene—plain black and white on the left, posterized to 4 values on the right.

colossaladvent_B&WLighting.jpg

So you can see that the reference image is much simpler than yours. The sky is overall lighter than the dark mass of the trees and ground, and the windows are brighter than everything except the moon (which has less contrast since it’s surrounded by light sky). The main contrast in your screenshot is bright moon thingy against the dark sky, and there’s patches of light stuff all over the place.

So, my recommendations, to make it more like the reference:

  • lighten up the sky a lot.
  • reduce the intensity of the sky light a good bit.
  • crank up the emissive power of the windows a lot, they should bloom a bit (if you have bloom on. (you should, it’s beautiful))
  • darken the light areas of your textures a bit, if that’s not way too much work (photoshop’s batch processing feature is amazing for this sort of thing).
  • lower the angle of the directional light to get longer shadows from the trees and stuff.

I did a little photoshop paint-over just to see what it might look like:

colossaladvent_B&WLighting_2.jpg

[Edit] - I’d make your directional light more blue as well, it doesn’t really match the moon right now.

Lighting Update

@Jenny Gore: Okay. I see now.
@-Ross: Thanks alot! The breakdown really helps illustrate things clearer. I’ll definitely head that direction (once I figure things out).

Alright I think I’ve resolved some things but created more problems.

I notice that when I toggle directional light (any setting) on and off, shadows appear for a moment. Once I “bake lighting” it goes flat as shown below.
I read that “Epic Setting” for Shadows is required for AO or something. It didn’t resolve anything and made self-shadows darker.

**I read that LightmassImportance becomes irrelevant and baking time speeds up with Generate Mesh Distance. Apparently it was reccomended for alot of foliage, so I did accordingly. **

The meshes appear to self shadow but does not cast any. I’m unsure why that is. I implemented the “Generate Mesh Distance” and “Two Sided Foliage” to fix foliage lighting issues.

I’ve played around with the intensity of lights and exposure but still nothing. I’ve even increased the Landscape “Static Lighting Resolution” to 5 (as recommended). However, there is no shadow in preview or bake, which is also strange.
https://forums.unrealengine.com/showthread.php?4149-Shadows-not-baking-on-landscape

c5c7a35772a39d479ddfa2a13dc3186d91b74b56.jpeg

Well, I rebuilt everything in a new level and things appear to be normal again. Not sure why thing’s got so out of hand.
I should be good on lighting issues from here on out. Thanks for the help everyone.

663ef9adc9e3739642e20cceb5f093ef4868a7b7.jpeg