Need to improve FPS in Quest app. FPS is as low as 16-20

Hi! I’m getting a very bad performance out of a basic scene from UE.26.2 to Oculus Quest (one). I have read a few posts, and tried to disable/enable some things, but nothing really seems to help. The model is meshes from Archicad, however there are only three objects in the scene now after I did some merging.

The FPS is really bad, chugging at max 20. That is directly from the Oculus, and not preview from UE4. Not that it matters, it’s the same in the preview.

Here’s the test, if somebody wants to give it a go. Dropbox - vrtest1-armv7.apk - Simplify your life

It can’t be a chance in heaven that the Oculus should perform that much less than Vive, which runs it at native fps.

At least a basic scene like this should reach 70fps in the Quest without any trouble. Right?
Any help appreciated!

I guess the cause might be some project setting of type of lights.
Did you read/try these threads?

From what I read from other people, OpenXR isn’t quite ready for prime time. Some projects prob show the issues more than others. I just know my project runs 70+ fps in 4.25.4, and the same setup in 4.27 (openxr) is like Chromaloma, 14-16 FPS

I disabled OpenXR for this project, and left OculusVR on. Both on at the same time gave me errors in the build. Just a note. I never though of OpenXR as a real alternative to the OculusVR plugin. That said, I understand from what you say that it won’t make any big difference using OpenXR before OculusVR.

Thanks for these links. I will do some testing and report back with my findings.

And wow obviously I was logged in with another profile on my phone. But I am chromaloma. :laughing: