Download

Need Help with Region's Sampling

Hey folks.

I’m new to all this unreal stuff so bare with me.

I’m trying to sample particles using Niagara on to my character’s mesh. - So Far that went well, i can do that and keep them updated with the module all good there.

But then i decided i wanted to only sample the arms of my character with the particles, and then everything went sideways.

I got as far as creating the sample Regions in my Mesh. and then putting the settings in niagara, but it doesn’t seem to have any effect, and i could really use a bit of help here.

Thanks in advance.

Thanks for the help in advance!

Hey Posted this a few Days ago, still hoping anyone may be able to help. Cheers

Everything seems to be ok.
I ve done exactly the same steps as you. Instead of using a customized character, I’ve used Unreal Mannequin.
Putting the exact same option in ‘particle spawn’ that is ‘Intitiazize mesh reproduction…’, and configuring an area in the bones as you did, gave me good results. Particles were emmited well only in the bone of the head in my case.
I reccomend you to try to repeat the test in Unreal Mannequin and see if works ok. Then it could be a problem of the character.

I see Thanks a lot Moli, will do.

I’m having trouble with the same issue as well. I’ve gotten good results using the “Skeletal Mesh Location” module, but it looks using Skeletal Mesh Reproduction makes the particle material creation simpler. But likewise, I can’t seem to get sampling to work correctly at the moment. If I figure it out I post it up here. If you need an urgent fix, try using Skeletal Mesh Location. If you don’t care about reproducing the color of the sampled mesh, then it should be pretty simple to set up, and uses the same sample regions.

Like with many things in Unreal, the solution is simple, but the editor gives no warning about it. @Lokerian You have to make sure your emitter is a CPU Sim, not a GPU Compute Sim. Region sampling only works on the CPU, which is why the emitter asks for CPU access when you set a preview mesh that does not have this setting enabled:

It looks like you can still do a GPU Compute Sim for Mesh Reproduction, but one limitation is you have to sample the entire mesh. Don’t quote me on it though, there might be other caveats.

Facepalm Thanks for updating!. >.<