Download

Need help with Better Performance with Editor while developing.

Hey Guys,

It’s been while and I have been super busy. I am running into some performance issues with the Editor and I really need some help turning down or turning off
some settings while in development that are punching my computer’s lights out.

What project settings or editor preferences can I turn off or turn down to get better build times?

Also, when I run the game in view-port, my heat goes way up and I have a small map. I cannot imagine what performance will be like if I continue at this pace…

I might need a computer from NASA or something…(LOL). In other words “The Performance killer Troll” is out to get me in the woods…

Please Help Isabella.

Thanks,
Isabella.

What GPU do you have? Are you using a laptop? Are you using baked or dramatic lighting? Have you tried looking into the performance profiling tools?

Hi Zach, thanks for replying.

I have a Nvidia Geforce GTX 1060 with 8GB if Vram. I have the Nvidia forced to “performance” on the control panel settings. My CPU is an overclocked Intel Core™ i-7 8750H CPU @ 2.20 GHZ but there is overclocking software that will push it to almost 4. GHZ. The problem with is that it generates way to much heat so I have to throttle it down.

I just turned off “Motion Blur” in Engine - Rendering to “off” that helps allot.

What other things can I turn down to get better performance when I run the game in stand-alone?

How do i know if i am using baked or dramatic lighting?

Thanks,
Isabella.

How do i know if i am using baked or dramatic lighting?
i guess he ment dynamic lighting. Check your Light Mobility: Is it static (baked) / stationary (hybrid) / movable(dynamic). Movable lights cost very much. When you type in: stat unit / stat gpu you can profile your scene. When you type in stat gpu on the console( Strg+Alt+Tilde) you can see the value ShadowDepth .This is a rough representation of how much performance your lighing costs

Thanks allot, I will check into that!

Thanks,
Isabella.

Without seeing what you have on your scene it’s hard to make anything but random guesses. A 1060 should handle pretty complex scenes, so you are probably going way overboard in some aspect. Also, please define what are your performance problems because you mentioned build times and now it’s not clear if you’re having slowness moving around the editor or building lighting or something.

@IsabellaRkt Hi there Isabella.

From the description of your setup, it would run fine if it was not a notebook, and your issue is related to heat. The more heat your system gets, it will automatically decrease the clock speed, which in the end will make your system throttle and notebooks are very sensitive with elevated temperatures, which can cause malfunction with hard drives and usually does. Even if you add those fan tables bellow your notebook (like this one: here), there is still other things to take into consideration like the ambient temperature (if it is hot, you will blow hot air anyway). The only solution would be having a desktop equipment with a large case with enough in and out take fans, also prefer air cooling with beefy coolers.

Thanks Guys, I turned some of the Render settings down and then went to just “preview” lighting. I am now getting better performance.