Download

Need help to understand how lighting/materials work in UE4. :(

Hi everyone! I’m an artist very new to the unreal engine. I’m from a 3D max background, and hence a lot of things are very strange to me. If possible, I’m hoping someone could help me with understand lighting/materials in UE4.

This is how my orc looks with directional light(static), the skybox etc
0bc745ace36208dd9450dd5a9f16a38d7fdb0703.jpeg

This is how it looks with the skybox/atmosphere turned OFF. Why does it become so bright?
ffabfb5c6bd51dca03b05aded05ffb0017fecbaa.jpeg

Now this is with all the lights disabled/turned off. Why is the model still visible? Shouldn’t it be pitch black?
26e707b062cc74b71c4cefc6569a1de8652d7c95.jpeg

Sorry, I’m super new to all this and all these confuse me as it directly contradicts how things work inside 3D max! Please help! :slight_smile:

When you play the game it should turn black, because it’s just the preview -> otherwise you wont see anything in the window + you wont be abel to place new meshes (as you cant see where you place them) :slight_smile:

I tried pressing ‘Play’ and it’s still as bright as in the screenshot… :frowning:

Ok, then you either have a light in your scene (skylight, directional light) or you have used “emissive” in your material -> when you use emissive it will have an overall brightness

If you’re disabling the light by using the World Outliner and the visibility eye this does not disable the light source.

If you want to disable the light source you need to delete it from the scene or select it and go to the details panel and uncheck “Affects World.”

Maybe this is the issue?

Hmm, I checked everything you all mentioned…

a16e47a8e80076eb0d210c0b049bc4723b8c7200.jpeg

I only have 1 light, and I turned off ‘Affects World’. (I also tried deleting the light, same effect)

My material has no emissive either…

Is there like a universal light setting in UE 4 or something? Maybe that is turned on, that could be why?

Looks like indirect lightning. Try to rebuild lights.

Because of eye adaption/auto exposure. You can disable it by placing a post processing volume and giving min/max values an equal number. (2 is my favorite) and also give bias a value (1.5 to 2 is usually a good range).