Download

Need help, Lightmass produces weird shadows on simple model created in Blender

Hi, I’m a newbie, trying to import a hammer I created using Blender from this tutorial, using FBX format. When I use baked lighting using stationary directional light, it looks weird as if the normal is broken, as seen below:

However, if I use dynamic directional light (no precomputed lighting), it looks just fine as below:

I have tried to remove doubles, it doesn’t work.
I also have tried to fix the overlapping UVs (using Smart UV Project) as seen below:

I am not sure what I should do here or which causes the problem for now. Any suggestion?

If that’s going to be an object that characters can pick up then you don’t need baked lighting on it.

Otherwise, check your lightmap resolution, by default its 64 x 64 pixels, also make sure your lightmap coordinate index is correct, by default when you import something it will try to generate new lightmap UV’s to a new UV channel, if you’ve created yours already then you want to turn off that option. The general workflow is that the first UV channel (channel 0) is for your material and the second (channel 1) is for your lightmaps and it will use the second channel for lightmaps if it exists.

I ran into this a lot coming from blender/not being familiar with lightmaps/ue4.

+Make sure that your UV’s are spaced enough so that they don’t overlap. If they overlap, you’ll get that blackness. UE4 generates a light map, sometimes it overlaps in the UV’s… so as Darthviper said, make sure you’re using the non-overlapping UV – it looks like you could space out yours a bit more just to be safe. Just nudge them a few pixels away from eachother… might also help. in ue4 – Double click on the object, and you’ll see options to view UV channels in that viewer window that pops up. It will say 1 or 0. Then you can select which channel you want in the properties.

It may have thrown an error on import, maybe smoothing groups and something like “overlapping UV’s channel 1” Which I thought for the longest was my UV’s made from blender, I kept re-uving… but it turned out that UE4 was defaulting to a channel that had its created lightmap, which had overlapping uvs.

Good luck.

I was trying for hours to “clean” up the model in blender, but it was just the UV’s. UE4 uses UV’s to bake lighting to. So depending on their setup/resolution, that has an effect on your shadows inside of the engine.

Hi guys, thanks for the quick response. I managed to solve it by increasing the lightmap resolution to 512 or more, as seen as below:

However, there are still some minor errors if you really look at the picture. I tried to manually adjust the UVs to give space but it doesn’t solve it.
I think it’s minor issue visually to me, but I let you judge whether the result okay or not technically as I’m not sure if it will be (or is) a big problem in the future or not.

Speaking of thrown error on import, I forgot to mention that there is a “smoothing groups” error though, which is as the following:
"FBXImport: Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the ‘Export Smoothing Groups’ option in the FBX Exporter plug-in before exporting the file. Even for tools that don’t support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can
be inferred while importing. "

Does this has anything to do with it? If it is, how do I solve it? I can’t seem to find any “Export Smoothing Groups” option on the FBX export. It’s Blender 2.8.

Happend to me too, might be a thing with Blender 2.8 and UE4, creating a new project solved it for me though. You can find smoothing groups under mesh when you export as fbx and choose face if you used autosmooth or edge if you used edge split.

Thank you Derelict Assets, I used auto smooth for the hammer, and choosing face as the export smoothing option removed the warning completely (I didn’t create a new project, just exporting a new fbx file with different option).

I think I’m good so far with the issue, thanks guys.