Download

need help! cant connect to android console!

after updating to version 4.7.3, the engine cant recoginse and connect to my android phone (samsung note4).
but the earlier version was ok. actually my computer (win 7) can connect the phone and everything ok.
now i am confused.
can you give me some help? thx.

Hi tony_99,

So your computer recognizes the device ok? Can you see the connected device on your list when you use the command prompt adb devices?

Thank you for your attention.
Yes, my computer can recognize the android device.
but there is no activity android device in the device list of UE4, only Windows and apple IOS.
so this makes me confused.

could you please tell which command that can manually add the device to the UE4?

thank you a lot.

Are you working in the editor itself

or the project launcher/unreal frontend

Hello tony_99 ,

It’s something was happened many time , i dunno why !
Launch UE4 editor and kill adb.exe proccess , next, connect your device to pc and restart UE Editor .

If this doesn’t work , try it :

Connect your device to your computer
Launch UE4 Editor and Open a command prompt
type :


adb reboot 

Wait 1 or 2 minutes and restart UE4 Editor.

I dunno how i fixed it , but now it’s work just fine but sometime it’s happened that i don’t see my device within the editor.

I hope this will help , good chance.

thank you for your kindly attention.
a.PNG

above pic i have taken did not make me clear whether my android works ok or not.
if it seem ok, why ue4 can not connect it ?

Hi tony_99,

Can you look this post with the pictures and tell me where you’re not seeing the device connect?

Hi wittlief,
Thank you first, let me tell you the situation of my side through your pic, here it is:

Last night i have tried couple methods from the web, but little worked.
i have carefully think over each process i had done, i found something:
1st, i updated the UE4 version to 4.7.3.
2nd my samsung phone has been automatically updated its system, too.

So last night i have to uninstall the UE4 totally, and today i will reinstall it.

Alright, now we’re getting somewhere. When you connect your device can you see it in the editor, the other picture, as if you were preparing to launch on? I am assuming that USB debugging is enabled on your device if adb devices can recognize it, but here are some things to check if you can’t see it in the launch on menu of the editor itself. Could it be that your device had its debugging reset when its system was updated?

This is probably not the problem but it has come up from time to time in internal testing. Can you try a different USB cable and see if that helps?

Hi Wittlief,
thank you for your kindly support.
i have got your ideas. Inorder to fix this problem, i have tried some methods again last night, and got little achievement which makes me happy:
First i have tried some other android consoles, nothing works. Then i decided to install UE 4.6 instead of 4.7. Before i installed it, i have totally deleted all involved files including the registry. Clear up!
Second, i have deleted all android usb connecting drivers, too.
Ok, After UE 4.6’s install was completing, i did try through my android pad (Samsung). Install the usb driver, reset the debugging, and using the command of " adb devices" then i can see its ID code.
In the last it is very happy to see that the UE system recognized this android console.

Well, today i will recheck the Samsung Note4’s drivers because last night it can not be successfully installed with the part of CSC driver.
And the second step is to install the version 4.7.3.
Oh dear God, give me some luck, pls.

Fingers crossed for you! Lemme know how it worked out!

Hi Wittlief,
Thank you! It took so much time to install UE 4.7.3 that it was from 7:30 P.M. to next day 2:30 A.M., maybe because i am in asia.
That maked me exhaust, so i will continue the work today.

hi Wittlief,
After a few testing, i think i maybe find the answer that why UE 4.7.3 can not find the android console: it is a bug or some kind of error.
Because i try the same with UE4.6.1 (pic here:)


so everything is ok, both the samsung note4 and pad eventhrough i did not install the csc driver!

At the same time i also ignite the UE4.7.3, but it still can not find the android, pic:

So, i think the version 4.7.3 maybe has some problem with connecting some android console. Do you know whether some met the same problem with the 4.7.3?
if i am right ,could you please send this info to the engineers who can improve and correct this for everyone?
if i am not right, could you please tell me where can i download the older version of 4.7.2 or 4.7.1?

thank you very much again!

Well, I’m pretty sure it’s not a bug with 4.7.3 because those screenshots above are from my console which is running that version, and it could see the device. I’m afraid I’m not able to reproduce the issue on my end. Are you seeing anything else that’s different? Have you tried with a different Android device?

hi wittlief,
in my hand i have tested android phone and pad (both samsung).
another information:
When i open both 4.7.3 and 4.6.1 at the same time with one computer, i found the 4.7.3 can find the android console in the launch (but device list is still empty) while 4.6.1 can find the console.
so what could the problem be ?
thx.

That is a fantastic question. Can you move this over to AnswerHub so we can track it a little better? Here are the instructions on what info should be included in the report, andhere is how to locate logs for including in the report.

I’d also really like it if you could include a screenshot of your environment variables, as I did a quick search of AnswerHub issues relating to the editor not being able to recognize devices, and they seem to be related to environment variables, so I’d like to rule that out, also.

Thanks much! We’ll figure this out.

hi Wittlief,

hi Wittlief,
the pic above is my screeshot from which i have dual screen with one pc.
i will send this information to the Answer Hub as following your suggest.

thank you again.

hi wittlief,
i have post this problem to Anserhub, the link is:
https://answers.unrealengine.com/questions/201879/after-updating-to-v473-the-ue-can-not-connect-the.html
thank you so much!