Need help asap! Foliage not erasing

Hello! I tried placing foliage on a static mesh (the mountains in brushify) & it wouldn’t let me use the paint tool so I had to use the fill tool & now I can’t delete the foliage and cant alt z (even if I could I wouldn’t because I did stuff) i don’t want to delete all my foliage only the ones that are/were on the mountains, I tried deleting a mountain but foliage stayed. This is quite annoying… Here are some pics I cant use the paint tool to erase the foliage only on landscape. alt text

Do you have the correct meshes ticked for erase?

1 Like

Yes i do, i only have 3 trees used

Another thing you could do it just click one icon and then hit the del key, it will only remove that foliage type.

I have 3 trees used in the level, I don’t want to delete them all

and remove or lasso select doesn’t even work, you would think a multi-million/billion-dollar company wouldn’t have such huge bugs

top view?

mesh in select right level

Soooo,people who work to do this dont respond?

These bugs are going to kil your engine & that’s why people use unity… this is the dumbest ■■■■ ever, cant erase or paint on static meshes only fill but then cant delete

I have to redo the entire level thanks to stupid bugs that are so simple

Thats not an answer thats a question, now people think that this is answered, why would you do that…

What… please write in English & correct I don’t understand… Also it is top view

In UE5 Erasing of Foliage with World Partition enabled does not work (tested with Erase Density 0, and Foliage Mesh enabled).

1 Like

in my case,
just check the static meshes filter button in foliage mode again
so that the brush can snap on the meshes surface
then I can remove them

hope it can help

1 Like

Hi, i have thé same problem, also with the brushify landscape mat. Have tou find any solution? I’ ve tons of foliages and i really don’t want to do it again :frowning:
Have a day

I had this exact problem and fixed it by making sure you have the foliage in your level checked marked under your foliage panel. For some reason you can’t erase foliage unless its specifically selected in that panel.

Still doesn’t work for me in unreal 5.1, even selecting static meshes. I can select but erase does nothing. I can erase folliage on the landscape though

You have to make sure you tick mesh or any other form of collider it spawned on, e.g. painting foliage onto terrain needs you to erase with terrain ticked, if it’s painted onto a mesh, you need to tick mesh for erasing. @diego.ba7op