Download

Need Guidance on GearVR and Unreal 4

Hello,

I am trying to develop an app that will work with GearVR and the only information I am finding is related to Oculus VR. Is the workflow for GearVR the same as OculusVR? If not, can someone please layout a straight forward process to develop and test from Unreal 4 to GearVR?

I have downloaded this( https://developer.oculus.com/downloads/mobile/1.0.0.0/Oculus_Mobile_SDK/ ) SDK, but it doesn’t have an install option. Do I need to copy these files directly to my phone?

ALSO, if you’re interested in supporting me please let me know. My idea is original, its not a game, but will be heavy on Blueprints and content.

This is what you need. https://www.youtube.com/watch?v=PXGe-O_PWVI

and also watch this

https://www.youtube.com/watch?v=rNjDsNYvgfk

Lasyavez,

I actually saw the first video, but stopped when he said it only works for C++ and not for Blueprints. Is this still accurate? Because I would much rather develop in a Blueprints environment and I believe that is what version 4.10 advertises, its improvement for VR content.

Update:: Is it safe to say I would need to be a C++ programmer to use VR and Unreal 4 at the moment?

No you will not need a C++ programmer to get Unreal and Gear VR to work. You also no longer need to make the project a code project to get this to work. Gear VR can now use a BP only project to work.

Actually all you need to do is this: https://docs.unrealengine.com/latest/INT/Platforms/GearVR/QuickStart/index.html but as it says at the beginning you can set it up as a blueprint project since 4.8 not a C++ project :wink:

Looks like Sam has it up to date to version 4.9 however one setting missing from the guide is this one: https://forums.unrealengine.com/showthread.php?91232-GearVR-Simple-app-displays-werid-quot-Pause-Download-quot-screen-when-inserted&p=420937&viewfull=1#post420937

Hi Teriander,

4.10 binary has the GearVR plugin compiled in by default so you can do a Blueprint-only project. Follow the normal steps of getting an osig file for your device and place it in the proper place for packaging, set the minimum and target SDK versions to 19, and enable “Configure the AndroidManifest for deployment for GearVR” checkbox in Android Project Settings.

Fantastic news! You guys at Unreal rock. Somebody buy Chris and Sam a beer for me.

Chris, I have run into a problem. Last night I tested with the C++ build, and it worked fine. Today I tried with a new project in Blueprint mode, and I received the following error message. I also attached screenshots of my settings. Also I packaged with Android (ASTC). What am I doing wrong?:

UPDATED :::::: Nevermind Chris. I’m not sure what was wrong, but I restarted Unreal and it worked this time. Thanks again!!

http://img.photobucket.com/albums/v72/Teriander/GeraVR_Screenshot_001.jpg

http://img.photobucket.com/albums/v72/Teriander/GeraVR_Screenshot_002.jpg

http://img.photobucket.com/albums/v72/Teriander/GeraVR_Screenshot_003.jpg

The guide doesn’t mention it but you need to check the box in the android settings for, “package game data inside .apk”

Good tip, thanks BluebyLiquid!

I tried that, but it makes no difference for me in 4.10 - I always get black screen in Gear VR :frowning:

Try to preview your device without putting it in the HMD.
What prompt do you get without the phone inside the headgear??

How would I do that?

When I launch the build I get same standard prompt about inserting phone into GVR. So when I insert it, nothing happens, just black screen.

A few things to check:

  1. Just to make sure does your app show on your phone without “configure the manifest for gearvr” ticked? (then you know it’s a problem with your app and not any gearvr settings)

  2. You have no OBB file when you’ve done your export (otherwise “package game data inside .apk” was not ticked - all content needs to be in the APK). If you see that download screen you see in your last comment here: https://forums.unrealengine.com/showthread.php?92690-4-10-app-doesn-t-run-black-screen&p=427517&viewfull=1#post427517 then you know it’s trying to download the OBB file so it wasn’t packaged in your APK

  3. The most probable: Are you sure you have your OSIG file placed correctly? (“Remove Oculus signiture files from Distribution APK” needs to be unticked!) I find I need to place it in the engine itself. You can tell if it was packaged in the APK correctly by opening your exported APK with winrar and you will see your OSIG file in the “assets” sub folder

@aussieburger: Yeah, I tried with and without OBB file - same issue. I’ll try building without “configure the manifest for gearvr” ticked.

I have 2 OSIG files (I have 2 phones for testing) in *\Epic Games\4.10\Engine\Build\Android\assets\

So, building without “configure the manifest for gearvr” ticked produces conventional mobile FPS game I can play with two touchscreen thumbsticks.

I get the two touchscreen thumbsticks as well, in both GearVR and building without GearVR. Also, where is the option to disable the touchscreen thumbsticks? I did not see them in the HUD blueprint, only an option to modify the crosshairs.

Ook, got some progress - apparently I turned off Paper2D plugin. After I turned it back on, and rebuilt, I am getting the following message when in Gear VR (the app asks me to insert the device into Gear VR, which I did, and black room with blue floor loaded):

Thread priority security exception. Please make sure APK is signed.

As I mentioned, I already have 2 OSIG files where they belong.

Hmm… UE4 is one annoying engine to work with when it comes to Gear VR. I am gonna have to stay with Unity until Epic figures it all out for Gear VR :frowning:

I’m pretty sure Epic is still working out the best methods and features for the Unreal to work with Gear VR. Keep in mind, this is very new technology to everyone.