Download

nDisplay on singl 4k LCD for testing

Hello, I have a little problem. I used config settings from Ben Kidd. When I set the resolution to 1920x1080 everything works fine. I have a 27 "monitor with a resolution of 4K. If I set the resolution to 3840x2160 every time the engine crashes. Can I ask for advice? I have an assembly with one computer and one screen.

Here is the settings

[info] version=“23”

[cluster_node] id=“node_1” addr=“10.0.0.5” window=“wnd_1” master=“true” sound=“false”

[window] id=“wnd_1” viewports=“vp_1” fullscreen=“false” WinX=“0” WinY=“0” ResX=“1920” ResY=“1080”

[viewport] id=“vp_1” x=“0” y=“0” width=“1920” height=“1080” projection=“proj_simple_1”

[projection] id=“proj_simple_1” type=“simple” screen=“scr_1”

[screen] id=“scr_1” loc=“X=0,Y=0,Z=0” rot=“P=0,Y=0,R=0” size=“X=0.595,Y=0.35” parent=“display_1”

[camera] id=“camera_dynamic” loc=“X=0,Y=0,Z=0” parent=“socket_cam” eye_swap=“false” eye_dist=“0.064” force_offset=“0”

[scene_node] id=“cave_origin” loc=“X=0,Y=0,Z=0” rot=“P=0,Y=0,R=0”
[scene_node] id=“eye_level” loc=“X=0,Y=0,Z=0.285” rot=“P=0,Y=0,R=0” parent=“cave_origin”

[scene_node] id=“column_1” loc=“X=0.6,Y=0,Z=0” rot=“P=0,Y=0,R=0” parent=“eye_level”
[scene_node] id=“display_1” loc=“X=0,Y=0,Z=0” rot=“P=0,Y=0,R=0” parent=“column_1”

[scene_node] id=“socket_cam” loc=“X=0,Y=0,Z=0” rot=“P=0,Y=0,R=0” parent=“eye_level”

[input] id=“ViveVRPN” type=“tracker” addr=“openvr/controller/LHR-FFFFF940@192.168.29.224:3884” loc=“X=0,Y=0,Z=0” rot=“P=0,Y=0,R=0” front="-Z" right=“X” up=“Y”
[input] id=“MAxis” type=“analog” addr="Mouse0@127.0.0.1"
[input] id=“MButtons” type=“buttons” addr="Mouse0@127.0.0.1"
[input] id=“KButtons” type=“buttons” addr="Keyboard0@127.0.0.1"

[general] swap_sync_policy=“1”

[network] cln_conn_tries_amount=“10” cln_conn_retry_delay=“1000” game_start_timeout=“30000” barrier_wait_timeout=“5000”

[custom] SampleArg1=“SampleVal1” SampleArg2=“SampleVal2”

Thank you and have a nice day.

Hey,

I ran into the very same issue and it only occurs when i have set the “Scale and layout” to more than 100% percent in the windows display settings. Most users with 4k displays will have that at 150% or more to be able to read the text. However, this also seams to affect the nDisplay app and the scaling of same.
In my case when it is set to 150% i can only run - ResX=“2560” ResY=“1440” - as max res in the nDisplay config, anything larger than that with the scaling on will crash the nDisplay app.

So solution is, setting the scaling to 100% in the display settings or set a smaller resolution in nDisplay.

Kikilo, did that solve your issue?

I have the same issue, I’m using nearly the same config file (except for the projection resolution) as kikilo but I still get crashes.

I have a small 1280x720 reference monitor set up running via an HDMI as my 2nd monitor (main monitor is on DP connection, not sure if any of that is relevant)

Can someone have a look at this crash log? It says at the end:

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff

UE4Editor_DisplayCluster
UE4Editor_Engine
UE4Editor_Engine
UE4Editor
UE4Editor
UE4Editor
UE4Editor
UE4Editor
kernel32
ntdll

**Edit: **One thing I literally just noticed which might be causing an issue:
in nDisplay Launcher when I go to select the UE4 editor (for Add Project in Editor-game), the file path to the editor is:

“Program Files\Epic Games\UE_4.24\Engine\Binaries\Win64\UE4Editor.exe”

So here’s a major problem I realize, my file path has two spaces in it, “program Files” and Epic games". Could this be the cause of the crashes? I recall the docs saying to avoid this, but I’ve also heard there’s no way to change these directories without screwing up Unreal!

As mentioned above, there seams to be an issue when setting a bigger resolution than the actual usable one by the output and on top nDisplay doesnt seam to take windows scaling into account.

What i would try for a test is:

  • make sure the scaling in windows is set to 100% (see above image where it says 150% set to 100%)
  • then set the screen size in the .cfg file to a lower or same value as your monitor is set to ( in your reference case max resolution of 1280x720)

If this works, then the issue is only the resolution setting.

If it still crashes, maybe install UE4 into a folder without spaces(but i am not sure if this is the issue)
Best practice should be anyway to never use spaces in any names or paths while working in code and development, make it a automatic habit to use a underscore( _ ) instead of a space and you always on the save side.
I always install my UE4 setups and projects in their own folders on a separate M.2 drive.

See if this helps.

Also, i just noticed with your file path that you still on UE4 4.24. When working with nDisplay i can highly advise to switch to 4.25, as nDisplay some major improvements like the “Assign Warp Mesh to Viewport”, what is a game changer.
I commented on a different post with some links and blueprints, that should be a good start for 4.25. ( Multicamera with nDisplay and pfm files - Unreal Engine Forums )

thank you, I’ve updated the project to 4.25 it’s a template by Ben kidd, the guy who seems to be the official nDisplay person on youtube, and it was in 4.24 so i was reluctant to update it since he had his working no problem.
But having said that, the issue seems to persist. i set the window resolution to 1280x720 to match, Launch it, but it still give me a black screen momentarily before shutting off:

What exactly is an Exception Access Violation?

hi, the problem is in the config. You need to have all the commands for the cave. I didn’t have them in my setup and it kept falling. Now I’m trying to use a static mesh for the projection.

https://youtu.be/8QHAGJeF38A

I was facing this issue. The way to fix this is to disable SteamVR and Oculus plugins on the project. That fixed it for me.

So far there is a major issue running any VR and nDisplay. It’s an odd crash where after the second time running VR Preview it crashes on ndill.