Navmesh won't show green areas

UE4: When I press P or tick the box in Show, the green does not appear from navmesh. The AI can run around the map decently, but I need to polish it and I cannot get the green to show in order to edit it manually at the glitchy spots.

I am looked around for about 30 minutes now on the forum and google, and all of the solutions that worked for others did not work for me.

I have tested on all of my maps, including brush geometry maps, and terrain maps, and it does not show.

SOLVED: I had to go into engine settings, navmesh, and enable drawing.

Do you have the editor in game mode? You can switch out of it by pressing G.

1 Like

I did not, and I tried toggling it on and off to see if that would fix it. Thanks for the idea, but sadly it did not work :frowning:

SOLVED: Had to go into engine settings, navmesh, and enable drawing

1 Like