Navmesh too far from edge of object

The navmesh is too far from the edge of objects, how would i reduce this gap
i am using blueprints

I’m guessing Agent Radius, navmesh generation parameter, is what you’re looking for. If you lower it the navmesh edges will be closed to object edges. One thing though - this will result in generating navmesh where your character normally wouldn’t fit through, and will result in AI getting stuck if path is found through such areas.



Where can i find Agent Radius?

There is a RecastNavMesh actor in the scene. When you click on it you get a bunch of options including Agent Radius.