Navmesh not covering entire area

As can be seen here,


my navmesh volume is not covering the entire area inside of it. There is an empty hexagon, and a border around the edge. Here is my bounds volume settings

and my RecastNavMesh settings

Does anyone know what is wrong?

Thank you.

The border is natural to Recast-generated navmesh - the navigation agent size is pre-backed into the navmesh itself, so that runtime pathfinding is faster.

The hexagon is caused by whatever is standing there. It looks like a collision capsule so it’s probably configured to affect navmesh generation (the CanEverAffectNavigation flag and collision settings).



The collision settings were the problem, I’m surprised it was so large an area being affected. Is there anything I can do to get movement paths in the border area?