"Navmesh needs to be rebuilt" after update to 4.8

Hey, I have problem with navmesh on my level after upgrate fro 4.7 to 4.8.

The level is the same, copy of the same project, navmesh exist on the map (green mesh) but in the game my pawns can’t move and there’s info “Navmesh needs to be rebuild”. I built path of course, but still there’s something wrong…

Is there something new i should know after move from old version?

My navmesh becomes broken if I change something in NamMeshRecast settings. I have same message “Navmesh needs to be rebuilt” and I think it’s a bug and it was in 4.8 Preview too.

Have you tried resaving your maps?

Cheers,

–mieszko

I tried this and it didn’t work. I have sub levels under my persistent level and if I load the persistent level, it keeps saying the same thing no matter how many times I rebuild my level. When I load the individual levels it doesn’t show the message.

Hi everyone,

I attempted to reproduce this on my end, however I haven’t been able to do so. Can you provide me with detailed reproduction steps that I can follow? Currently my sublevel containing the navmesh comes in and, on PIE no errors occur and my AI as well as my player are freely able to move across the navmesh surface.

Same problem here with the SurvivalGame project C++ series example, after change some in the navmesh from default map now build the navmesh but at play say need to rebuild and the bot don’t work…

Same problem here. After editing the settings of “RecastNavMesh-Default” (this is the navMesh that ist generated for the NavMeshBoundsVolume) noone moves anymore and unreal keeps asking me to rebuild navigation. Even if I tick checkbox “Force rebuild on load” noone moves and unreal asks me to rebuild navigation.

summary:
leave default navmesh settings → everything fine.
edit navmesh settings → “rebuild navigation” bug.

Hi rodneym,

What specific changes did you make to the RecastNavMesh-Default?

Hi Adam,
so today morning the bug was gone. I managed to reproduce the problem though: if I changed the cell size or Agent Radius of the navigation mesh (in the project settings or the RecastNavMesh-Default, regardless) Unreal starts aksing to rebuild navigation even though I rebuild. A restart of the editor is enough and the problem ist gone. BUT: The agent radius keeps resetting to 35 (from my lower values 25 or 20). And this reset occurs even if I change it in the project settings and the RecastNavMeshDefault.

summary: restart editor-> bug gone. But: Agent Radius resets to 35.

Cheers,
Rodney

This is a know UX issue. All you need to do is to add SupportedAgent to NavigationSystem. This is done via the project settings.

If download the survival series GitHub - tomlooman/EpicSurvivalGame: Third-person Survival Game for Unreal Engine 4 (Sample Project) and open in the 4.8, check the map default , you need to change the recastnavmesh cell size to something like 10, yes if you change from the project works but at rebuild without restart the engine etc don’t work and i don’t need the same size in all maps…

We currently don’t support per-level navmesh tweaking. We’re going to add that, but it requires a lot of decisions, like what happens if you stream one-param-set level into different-param-set? We won’t be able to merge the navmeshes. And stuff like that. It’s hard :wink:

Yes, I noticed same thing. I have same problem with 4.9.2. I ended up deleting the navmesh and create new using only default settings. The only parameter I could change without getting problems is the Cell Height. If I touch anything else I get the bug. I also noticed that UE crashes if you move the Navmesh in a folder in the World Outliner.

Hi Raed Abbas,

The crash is concerning, however it would be best to address it in its own answerhub post. Can you make a new post and include the following information:

  • Crash logs (\Unreal Projects\PROJECTNAME\saved\logs)
  • Callstack
  • Dxdiag
  • Steps to reproduce error
  • Whether this occurs in a clean, blank project with no additional content or is limited to one project
  • C++ or blueprint based project?
  • Launcher or Github editor build?

For the parameter changes, what steps are you taking for me to reproduce this on my end? Does this occur in a clean, blank project as well? Which specific parameters are you trying to change and where are you trying to change them?

Hello,
I have same problem. I am 4.9v.
A solution does exist ?

Hi I just fixed this in 4.9.0 by doing what MieszkoZ mentioned above in this thread on Jun 18 '15 at 11:02 AM:

“This is a know UX issue. All you need to do is to add SupportedAgent to NavigationSystem. This is done via the project settings.”

Give it a go!

This worked for me. Thanks MieszkoZ!

Unfortunately, that don’t work. Would there be another solution?

Hi gaga071985,

I looked a bit further into this and unfortunately at present the method suggested by Mieszko earlier is the only way to accomplish this.

Thank you for your reply. If I find the cause of my problem, I will share. Good evening .