NavMesh Generating differently for a similar mesh

I have a grid made up meshes (instanced static meshes), but when I use a tile that has a slight ‘dip’ in it, the navmesh generates strangely on it.

The collision I use is a simple box collision (I have tried all 3 Complexity settings just in case, with no luck)

To make sure the mesh was the problem, I swapped it out with a flat plane with the same collision setup which worked fine:


I have been playing around with navmesh options and collision boxes for a while (none of it making much of a difference), and I am really hoping someone here has some ideas where I could start to fix this!


Well, it looks like there’s something else standing there :slight_smile: Like a blocking volume or something. Can you enable drawing of all volumes and see if there’s anything there? Or is this runtime view? If so, is this located near your grid origin?


Hi Mieszkoz,

Thanks for taking the time to reply :slight_smile:

The screenshots with the navmesh showing is at runtime, the other 2 screenshots are in the Mesh Editor

The problem seems to always be there with Mesh1 and never there with Mesh2 (no matter if it’s at the origin or not).

Here’s another wireframe shot at runtime from a different angle (under the NavMesh). For some reason the little spot that generates is lower than the rest of the mesh?

And here’s similar shot showing the collision box and all volumes are displayed (except for trigger and procedural folliage volume, which I couldn’t enable). Note: The adjacent tiles are using Complex as simple to generate, so their collision volumes don’t exist.

Does this hint at anything you might be aware of?

This is no longer an issue in 4.9