Navmesh and elevation bug?

While testing my level, which is a huge building with pretty much all apartments walkable, i ran into an issue with the nav mesh.

This is the navmesh where it splits, navigation doesn’t work as it returns a partial path, meaning that it seems that this split line is not connected for some reason.

If i place a NavLinkProxy actor on the split line, it works, which is fine but i dont know why it wouldn’t work without it

If this normal behavior? if this a bug has been fixed in 4.12? any advice would be appreciated


Have you tried messing with the settings in your Project Settings->Navigation Mesh? Often you’ll need to increase settings such as Agent Max Height, Agent Max Slope, etc in order to get the Nav Mesh to generate over a steep surface such as a staircase or ramp.

Let me know if adjusting those settings makes a difference.


Yes i’ve tried every possible parameter, no luck, however i managed to get it working if i just move the mesh somewhere else. Which is not ideal and not really a solution

I suspect there might be a little bug within recast, i will try adding collision proxies and then increasing the stairs width to see if that fixes it

Let me know if that helps at all. If not, would you be able to provide the project so that I can take a closer look at what could be happening?

You can zip it up, upload it to Dropbox, and provide me with a link through PM on the forums:


I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day