navmesh and collisions

I want to make most of my geometry invisible to navigation in VR. I though that disabling or removing collision from meshes will simply allow me to walk through walls, but it doesn’t and static meshes even without collisions will block navmesh… (the teleporting beam is blocked by every static mesh)

My idea is to create custom navigation with many geometry being simply ignored when traversing through the environment. How can I make meshes be fully ignored when teleporting?

I disabled collisions, removed collisions, disabled auto-generating collisions on import(fbx), the only thing it does is prevents me from stepping on the mesh.