Nav Meshes disappearing in 4.20

In 4.19 this was still working.

The world is composited. The Nav Mesh Bounding Volumes are in the sublevels. I can generate navmeshes in the editor, but in some levels the navmesh isn’t there anymore when i reload the level (i was unloading the whole persistent level and then reloading it, not sure if it would happen if i only unload and reload a sublevel) or play the game (in others both work).

I’ve tried changing a lot of settings, but the only thing that helps is setting the nav mesh generation to dynamic.

I’m not sure if the navmesh isn’t saved properly or if its not loaded properly.

Is there anything I can try?


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


very odd, i managed to get it working, but the solution made no sense.

i increased the Tile Pool Size (which was already high), and then it worked. then i changed it back to what it was before, and it kept working.

no idea why that might have helped.

i also found that when i had navmeshes in the levels that were generated with Static, and then switched to Dynamic Modifiers Only without regenerating them, the navmeshes were very broken in game. Regenerating them fixes that though.

Did you learn a bit more what is really going on?

I have a 2nd nav mesh generated with supported agents in project settings. As I read, this is the correct way. I see both nav meshes generated in Editor, but by starting game, one of two navmeshes simply disappears completely. It’s complete disappears from world outliner when start the game.

any idea on this?