Nanite Tessellation and Displacement Not Working in UE5.4? Tried everything (maybe?)

I’ve been at this for hours now and UE (5.4) refuses to be nice to me on this :rage::joy:. So I recently started using the Landscape Auto Material tool / pack (created and provided by “Unreal Sensei” here: https://www.youtube.com/watch?v=5ju7wyvZGBI&t=2360s), but I’m encountering the same problem in every new project I try to use this in.

Essentially, when enabling nanite on my landscape, as well as enabling tessellations in my material which contains all the necessary displacement textures, the geometry doesn’t generate and I’m left with a flat surface on my landscape and no displacement. Here’s what’s required from what I’ve gathered after watching the video and other similar guides:

  1. Create a landscape and apply your material (containing all displacement textures / data):
  2. Make sure “Enable Nanite” in the landscape details panel and “Enable Tessellation” in the material are ticked:

  3. Rebuild the landscape nanite data and hay presto, 3D geometry.

Not so for me. Outside of the extracted project file from the “Unreal Sensei” tool, every other project I try to migrate the files to refuses to create any tessellation via nanite what-so-ever when I follow these steps.

I’ve tried three solutions that I keep seeing which are:

  1. Migrate all the files from the tool again correctly.
  2. Enable the “Nanite Displacement Mesh” plugin (although experimental) to offer an easier pipeline for nanite meshes:
  3. Include two additional command lines inside of the “DefaultEngine” file in the projects “Config” folder:

Nothing I do seems to be working, and I’m desperate to take advantage of nanite displacement for my latest project. If anyone could offer some feedback or advice or even ask for further comment about what I might be doing wrong, please let me know. Hours of work and research potentially thrown down the drain here if I don’t get this working :joy::joy::joy:. Cheers!

Did you check the Nanite debug views to make sure Nanite is actually working?

Yes, when I re-build the landscape after deforming it, the nanite overview shows that nanite is enabled on the landscape mesh. I was just gonna provide a little update here actually. So it seems that nanite displacement does work when I import a separate material from “Quixel Bridge” and add it to a static mesh with nanite enabled. It might seem to be the Auto Material within the tool itself which is causing the issue, but I’m still clueless.

Well… solved it. So, adding the command lines in the “Config” folder did do the trick, but problem was, I enabled tessellation inside the master material, and at somepoint didn’t enable it inside of the child material that was applied to the mesh. It works now, smh :pensive::joy:. Typical that it’s one of those issues you spend hours on, and then its just ticking a box to solve it! hahaha