Download

Nanite not enough detail (Trangles in Nanite view are too large)

Culling starts too soon resulting in triangulated geometry, Triangles (in Nanite view) are much larger than the surrounding rocks of the valley of the ancient environment. At a close range the mesh looks great, but when I move a bit further culling becomes too obvious.

I tried with different import scale for the mesh and also tried maximum settings for the Nanite Position Precision setting of the static mesh. I even set the .INI file for Nanite on higher settings:

r.Nanite.MaxPixelsPerEdge=2
r.Nanite.MaxVisibleClusters=6291456
r.Nanite.MaxCandidateClusters=12582912
r.Nanite.Streaming.StreamingPoolSize=1024
r.Nanite.Streaming.NumInitialRootPages=1024
r.Nanite.ProxyRenderMode=2

r.Nanite.MaxPixelsPerEdge = 0.5 Prevents the worst culling scene wide. But The meshes still have too large triangles compared to other meshes in the scene. It’s still very unclear to me why Nanite decides to give some meshes larger triangles than other meshes. Why it culls some geometry more. Will the import scale setting influence Nanite? It does not seem to when i tried to set it at 50. Maybe the size of the mesh in the FBX file itself should be larger, and Nanite does not look at the import scale in the import dialog?

It’s a 300MB Decimated Zbrush mesh (so there is quite a bit of detail in there).
For example some round geometry clearly becoming more angular when moving a bit away from the object.
I have a 3090GTX and 5950x with 64GB Ram.


I wish I had more control over how much Nanite compresses a model. Because even at the highest setting it begins to cull geometry too soon. Especially on hard-surface forms like cylinders. Even though they have plenty of detail up-close. So it should not be a problem for Lumen to just tone down the culling a bit at a further distance without any performance hit for these kinds of models/forms.