Download

Nanite Instance Cull Performance Issue

Hi,
We starting prototyping our new game in UE5, but in short time we encountered performance issues. And it’s kinda looks like a bug? Nanite Instance Cull use like 1/3 of our performance budged even when we don’t have single nanite mesh in level (plus other Nanite functions adding up)

.
On screen you could see Nanite overview showing no nanite mesh, and yet all nanite related stuff take up to half of your performance budget.
Our level is not that complicated, there is not much yet on it and we getting like 10-20 fps (GeForece GTX 1070, AMD Ryzen 7 2700X, 16GB RAM). When we still have some optimization to work, on ue4 on similar level we got 40-60 fps.

At this point I’m kinda lost, and not sure what could we do. Can we disable this Nanite related features? From documentation I understand Nanite should be much more faster (which shouldn’t matter anyway because we don’t use it).

Hello, same Problem by me. Nanite Instance Cull takes 90 ms. I have no Lumen, no Virtual Shadow Maps and No Nanite Meshes on Map or Activate.

Can everyone help?

Jörg

Hi, I found up, that using command r.nanite 0 in console help. Still I don’t get ue4 performance but its better.

Hi,
yeah, but then go my unaccounted time go´s higher.

I found nothing why.

Jörg