Nanite enabled pitch black surfaces

Can anyone help please, I have a problem, when i turn on nanite for some objects, they either have some or all surface goes pitch black. I am also using megascans materials/textures on them.
I checked the normals, and they are fine.
Anyone knows why this is happening and how to fix please?

I actually found the problem, if anyone has the same problem, it is because nanite can not handle two sided faces, so the material HAS to be only One Sided.

I am still getting some faces, it looks like it could be the normals, however i checked them and they are facing the right way. Anyone know why?

Disable raytraced shadows

1 Like

Thank you that worked!!!