Download

My variables constantly being reset to default

I have a map with some basic blueprints, and every time I start the project now, their values are reset to default. This is just basic floats and references. It’s 15 minutes of work to get the project back up to normal every time I open it, and it’s a major issue because I intend to release this project on the marketplace… it’s not going to fly if people have to reset their variables every time they start the project.

And please don’t say start a new project because I run into this bug all the time, in almost every project. It’s a disheartening bug or something that has stopped my progress in the past. I really need a solution for this.

Thanks for any help.

Edit: it’s not every time I start the project… but it’s constantly… I don’t know what makes it happen but I feel like I’m doing this every morning

Hi @Pinworm,

Sorry if this sounds like a dumb clarification, but when you say “reset” do you mean that the variables are set to the value they had when they were created?? So for example, if a Float had value of 2, it resets to 0 when you open the project?? Are you saving to disk by any chance?

A bit more details / BP screenshots would help.

Thanks

So how it works is I have a blueprint that follows a spline, and it has variables like “speed” “interp speed” “follows spline” and a reference to a spline path it follows.

By default there are some values like .1, .2 for speeds, and no for follows splines, and no reference to any spline paths.

But in my map, I bring my blueprints in. I change their speeds. I then assign them a reference to some spline paths I have set up.

Works great. I can close and exit the project, things are fine. But randomly, I don’t know what’s causing it, but it’s happening every day, the values are resetting to default values. So instead of my adjusted speeds, they go to .1, .2 defaults. Instead of having the spline references I set up, they have none. They’re all defaulted as if I just dragged a new blueprint into the world.

I am doing zero saving to disk and this happens in editor before run time.

To be clear: The values I am setting in my map are being defaulted to the default values of their class. It’s like my maps aren’t saving their settings.

I see. This is really strange and I’ve never had this issue on any of my projects. I don’t really have any suggestions except to post in the Answer Hub which seems to get looked at by Epic Staff more than the forums.

Are you using a save game at all? I’ve never heard of this either. I’d suspect they’d want a copy of the project or first ask if you’ve tried recreating it in a new example project.

https://answers.unrealengine.com/questions/416892/411-child-blueprint-variables-resetting-parent-def.html
https://answers.unrealengine.com/questions/574040/child-bp-reset-to-default-old-bug-still-exist.html
https://answers.unrealengine.com/questions/400807/child-blueprint-reset-to-parent-defaults.html
https://answers.unrealengine.com/questions/257788/child-blueprints-not-maintaining-values-set-by-eit.html

It’s a common and persisting issue that blueprints have.

Nothing was mentioned about child blueprints just blue prints.

I’ve experienced child blueprints having problems so I don’t really use them I setup blue prints to change variables on creation or posession because of this and reserve base prints for really basic things that don’t have variable changing on there own.