Download

My point light has an X over it

After build it says, “Severe performance loss. Failed to allocate shadowmap channel for stationary light due to overlap - light will fall back to dynamic shadows!”

Any ideas?

Take a look at the UDN

"Stationary lights are limited to a maximum of 4 being able to overlap at one time. Once you have 5 or more Stationary lights overlapping, the one with the smallest radius will start casting dynamic shadows, which have a higher performance cost. You will also get warnings when rebuilding your lights. Here you can see 5 Stationary lights placed close to one another. Notice that the fifth as a red X over it, indicating that it is now casting dynamic shadows. "

If you want to avoid that, change the lights from Stationary to Static.

2 Likes

I only had 3 stationary…changed to static but “source length” in static mode seems to have no effect. cries

Sorry to necro such as old thread, but I’m currently running into this as a potential conflict with my lighting goals.

Essentially the majority of my lighting would be static. However, I need it to flicker. Currently I simulate this by adjusting intensity of point lights. However, I cannot use static lighting because the intensity cannot be changed, and the number of stationary lights is limited to 5, so many times throughout my level there are at least a few lights that switch to dynamic.

Are there any decent ways to create many stationary lights with which I change intensity and not suffer huge performance hits?

They just can’t have more than 4 stationary lights overlap an area

I know that… Just… why? Would be so helpful to be able to modify that number or create some sort of override. At the moment either I have to take the potential performance hit or give up realistic, flickering lighting. Neither is particularly enticing.

I believe it’s a technical limitation due to deferred rendering. It seems like it should be easy to limit the number of stationary lights so that they don’t overlap, do you really have more than 4 things in an area that need animated lights?

Yeah, I kinda do. :confused:

I’m simulating candles, and a handful of the props from a pack I purchased have places where candles would be held. None of these look right by lighting an entire room, so I don’t want to use one extremely bright light.

And candles with flames but no light just don’t look that great. But to light the corners I need at least 4 alone. And each of these for sure need animated light intensity.

Its because the shadow maps have to fit into a 4 channel texture. You dont have more than 4 channels to store the shadow information so 4 is the hard limit.

1 Like

Okay. I see. Well alright then! Thanks for the clarification.

I have the same problem with the X over the lights … So Change the range for all of them or is there another way to go?

You need to change their attenuation radius, or set some of them as static, or disable Cast Shadows for some of them.

Just to summarize,
Stationary lights are awesome because they make things look more pretty than static lights. However, we can only have 4 overlapping each other with their “Attenuation Radius” with the “cast shadows” option selected. The real limit is having all four with “cast shadows” option enabled (click the light, look in the details tab. go to light section. see cast shadows option. uncheck) within each other’s Sphere of influence (attenuation Radius). So, if you don’t need all of your stationary lights to have “cast Shadows”, you can still get the other attractive lighting benefits. Go to the link below, press ctrl + f and type in “graph coloring problem.” In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color. That will hopefully…shed some light…on why we are limited to only getting 4 "stationary lights, with overlapping attenuation Radius, and cast shadows options selected. Also the link shows a color shaded picture to better drive it home.

https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/LightMobility/StationaryLights/index.html

Keep rocking,
Sean

What about IES on stationary lights. I want the IES effect. I guess I can turn off cast shadows on some?

Thanks, this was very useful for the lighting in my game!