My photogrammetry model has black triangles. How Do I fix this?

Hi, for the last couple of months i’ve been busy learning photogrammetry. For my bachelorproject I want to walk around in first person in my own room. Using realitycapture I made a 3d model of my room and textured it using texture reprojection. I decimated it to around 1 million triangles and it has 25 color textures and 25 normal layers all in 8K. The model looks very good inside realitycapture I exported the model with export to single texture file enabled (8k). When I imported the model and this texture in the first person shooter blueprint I notice that my model has many black triangles and looks bad.

When I view in unlit though it looks very good.

I did some research it know it has something to do with the lightmap UV’s. I tried upping the lightmap index and changing the lightmap coordinate index of the static mesh but this didn’t work. I also tried to disable the lightmap option when importing a fbx model which did’t work either. Since I’m very new to this program I don’t know what else I can do. Thanks in advance.

Hey bud, Did you fix this? I have also same. Pleasse guide me if yes :slight_smile:

Hi, I had the same problem with the imported photogrammetry models. The workaround that I found was changing some settings on the import model settings popup.


I found it. I am using Reality capture to make meshes. Whenever you are export must include Normals if doesn’t you will get jagged edges. Inside Unreal must check Use Full precision UVs.