My new C++ project won't Compile

Here is the error message

The project could not be compiled. Would you like to open it in Xcode?

Running Mono…

Setting up Mono /Users/Shared/Epic Games/UE_4.18/Engine /Users/Shared/Epic Games/UE_4.18/Engine/Binaries/Mac @progress push 5% Parsing headers for BuildingEscapeEditor Running UnrealHeaderTool “/Users/saudnaumani/Desktop/Unreal Projects/BuildingEscape/BuildingEscape.uproject” “/Users/saudnaumani/Desktop/Unreal Projects/BuildingEscape/Intermediate/Build/Mac/BuildingEscapeEditor/Development/BuildingEscapeEditor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed Reflection code generated for BuildingEscapeEditor in 12.1058972 seconds @progress pop Performing 6 actions (4 in parallel) [1/6] Compile SharedPCH.Engine.h In file included from /Users/Shared/Epic Games/UE_4.18/Engine/Intermediate/Build/Mac/UE4Editor/Development/Engine/SharedPCH.Engine.h:138: In file included from /Users/Shared/Epic Games/UE_4.18/Engine/Source/Runtime/Engine/Public/EngineSharedPCH.h:300: Runtime/CoreUObject/Public/UObject/UnrealType.h:3285:37: error: lambda capture ‘LocalMapLayoutForCapture’ is not used [-Werror,-Wunused-lambda-capture] [LocalKeyPropForCapture, KeyPtr, LocalMapLayoutForCapture](void* NewElementKey) ^ Runtime/CoreUObject/Public/UObject/UnrealType.h:3298:41: error: lambda capture ‘LocalMapLayoutForCapture’ is not used [-Werror,-Wunused-lambda-capture] [LocalValuePropForCapture, ValuePtr, LocalMapLayoutForCapture](void* NewElementValue) ^ Runtime/CoreUObject/Public/UObject/UnrealType.h:3808:47: error: lambda capture ‘LocalSetLayoutForCapture’ is not used [-Werror,-Wunused-lambda-capture] [LocalElementPropForCapture, ElementToAdd, LocalSetLayoutForCapture](void* NewElement) ^ 3 errors generated. ERROR: UBT ERROR: Failed to produce item: /Users/username/Desktop/Unreal Projects/BuildingEscape/Binaries/Mac/UE4Editor-BuildingEscape.dylib Total build time: 37.90 seconds (Local executor: 0.00 seconds)

I’ve tried uninstalling xcode and unreal and reinstalling them but it still doesn’t work

Im hitting this as well. Not a new project, but Just installing VS 2017. Seems to have broken the vs 2015 install.

Just install 2017, and build with 2015, (Which worked before the install), and your projects are broken.

Also the LocalMapLayoutForCapture is a reference being passed to the lambda as a copy. Probably isn’t going to work worth a darn anyway, its a good thing they aren’t actually using it.