My moving static meshes go black in packaged game - one stupid trick fixed it!

Hi,

just wanted to put this here to see if anyone else has had the same problem and knows more about it. I can’t really do a bug report because I don’t know how to reproduce.

In one of my several maps/levels the moving static mesh objects turn out black when I play a packaged version of the game. It works fine in PIE.

The objects Do get light from the single directional ‘stationary’ light but not at all from the baked volumetric indirect light.

I have tried things like switch light as static on and off. Setting the ‘Use with static Lighting’ option on the material on and off. Re-creating the object and re-baking the lighting.
My moving skeletal mesh characters work fine.
Nothing would make the static mesh objects become lit.

Then when I thought I’d try to take a look at the light samples themselves using the commad prompt instruction ‘show IndirectLightingCache’ it all started to work!
But I didn’t see any light sample points.
So now I have a command line node in my Level blueprint BeginPlay with that instruction and the lighting works. :stuck_out_tongue:
I don’t like it but it works and I can’t think of what could be the real cause and solution.

Has anyone else seen this and know what’s going on?

Cheers
Fredrik

EDIT: Actually the problem has come back. It works more often with that command it seems as before it would never work. I will try a little delay or something.

This sounds like a bug with cache invalidation. This, unfortunately, will not be fixed as we are no longer working on ILC anymore. However, you can use the new Volumetric Light maps which provides better results. To see how to enable and use this in your project check out the following page.

Thanks for the reply Sam.

Strangely it works in the Map I have set to use ‘Sparse Volume Lighting Samples’

And it Fails in the map I have set to ‘Volumetric Lightmap’.

(I I have just double and triple checked that)

Which I believe is the opposite of what you’re guessing?

For anyone else having problems with moving objects rendering black and you not understanding why, try changing the global Lightmass setting to use the older ‘Sparse Volume Lighting Samples’
That has solved the problem for me in two different Maps.
Of course the newer method is meant to be better but for me it was black objects or older method.

Cheers
Fredrik