My metahuman tab has disappeared from the quixel bridge app

I have been using the quixel bridge desktop app to export metahumans to maya and up until yesterday it has worked well.

Now when I open bridge the “my metahumans” tab has disappeared.

I can still see the metahumans that I have downloaded to my desktop but I can’t access any of the metahumans I have created.

I have uninstalled and reinstalled bridge but that did not help.
Does anyone have a clue what has happened?


Same here! No my metahumans in standalone or in unreal 5.4

1 Like

Same problem for us, and this comes at a really terrible time during our production.

This needs to be resolved ASAP so that we can continue to work with custom Metahumans in Maya.

1 Like

Also getting this error when accessing the Quixel website while logged in:


Are you all logged in?

I can’t tell from the photos, but sometimes you have to log in again, even though you’re already logged into Epic’s online platform.

Unfortunately we’ve tried being logged in, logged out, logged in again.

It also seems the UE5/UE4 Preset Metahumans are no longer initiating download for us in standalone Bridge either.

1 Like

Just to be clear, this is a new issue? You never experienced this before?

You’ve successfully used this platform to download and import MetaHumans?

Absolutely, we’ve been running our entire cinematic trailer production using Metahuman/UE5.3/UE5.4 for the past several months. It is only today, as far as I am aware, that the Metahuman downloads are failing to start or that the “My Metahuman” tab is failing to display or load.

Strangely, the MH Creator app loads fine, though I suppose that’s not directly connected to asset delivery so that doesn’t surprise me.

Here is a video showing the issue:

To be clear, I can access the My Metahuman tab within the UE5.4 Bridge, but obviously there is no way to export to anything other than that UE project itself, which completely breaks the path to Maya for our animators.


I see. Thank you for posting the video!

This is very strange. I’ll do some research on my end and hopefully you or someone else finds a solution before I do.

1 Like

My team is also having the same problem across the board. it seems Bridge doesn’t show the My Metahumans tab at all just like AhoyGame mentioned.

also have run into this issue today

does not seem to be related to what quixel version is installed.
Work computer has the latest, home computer has a much older version.
Same issue on both.

Same here, I can’t access My Metahuman via Quixel Bridge 5.2, 5.3, or 5.4 either. In the Quixel Bridge Standalone version 2024.0.1, there are no more My Metahuman UE4 or My Metahuman UE5 options, and I can’t download any Metahumans from the Metahuman presets anymore. I turned off the firewall and antivirus software (like Norton) and reinstalled all versions again. But still, the Quixel Bridge versions from 5.2 to 5.4 for My Metahuman don’t work anymore. I also checked the log file after trying to download a sample Metahuman from the Metahuman presets for UE4.

Here is the code of bridge.log,

{“error”:“hn is not a function or its return value is not iterable”,“stack”:"downloadMetaHuman (webpack:///app/actions/dhiAssets.js:57:9)

Additionally, the Megascans page on the website displays an error message.

If I try to download a sample Metahuman, Quixel Bridge goes blank, as shown below.

It is definitely an access problem to the Quixel Metahuman database, but I don’t know why. Only the server manager for the database can tell us.

I sent an email to Quixel Support Fab and received an initial response from them. However, they have sent me back detailed questions about the issues, as shown below.

Please share your creator version. Make sure that the Engine version should be the same as your Creator version. e.g UE creator 5.3==UE 5.3
e.g. A metahuman created for UE 5.3 will not show up in UE4 or UE 5.4
→ I understand, but in every UE5 from version 5.2 to 5.4, they have the same issues as above.
Are you having trouble accessing the Megascans Website?
→ Yes, I have. There is an error message, “An unexpected error has occurred.”
What region of the world are you in?
→ I’m in Seoul, South Korea.
Have you attempted utilizing a VPN? If yes, has it made a difference?
→ Nope, I will try later and I can send you if there is a difference.
Are you using any firewall/anti-virus?
→ Yes, but I deactivated them and uninstalled Norton Antivirus 360.
Are you having issues in accessing any other asset categories?
→ Nope, until today, I tried some other assets to download. It was fine.
Kindly go to stand alone Bridge>Help>Troubleshooting>show logs and share the Bridge.log file with me.
→ I attached the log file below.

I checked all the issues again today after using a VPN, but nothing special happened.

I hope to get a solution for the issues from Support Fab soon. Good luck to you all.


Reporting back to say this is still an ongoing issue for us. We’re completely halted on our trailer production until this is resolved.

1 Like

Same problem for me. and same result, cannot migrate to 5.3 for the ongoing project. if it’s a but it has to be addressed in a hurry…

Yes, I have experienced the same issue (in Seoul). I noticed the problem three days ago, so it might have started before that, but I remember it definitely worked before the recent Quixel update. It seems to be an issue within the past week.

Same issue in France.

Metahumans out, Quixel bridge grey when i click on a asset. And Quixel website unexpected error.

I’m totally stuck :confused:

1 Like

This remains an issue today. Haven’t been able to access “My Metahuman” in Bridge (and therefore Maya) since Thursday 23rd. Appreciate it’s the weekend, so we probably won’t hear anything new until Monday at the earliest, but keep keeping this thread updated in hopes it gets someone’s attention.

1 Like

This worked for bringing it back in Unreal, for standalone it just won’t let me download any metahumans as well as not showing the MHC metahumans.
I was having the same problem, so I found this thread. I went to try and download one of the presets from the Presets library based on what someone said earlier in this thread, it asked me to “sign in” (again!) instead of “download” and so I did, that’s when the My Metahumans tab reappeared. So far it’s generating/downloading my metahuman.

1 Like

Still not working for me. Signing out is useless.

My whole account is broken now. It started with the same issue with MH 3 days before and now megascans webbrowser crash when open. Bridge doesn’t work anymore with standalone, UE5.3.2, UE 5.4.1. Totally useless. The problem is, that lots of users are freelancers and have deadlines, we need to work. Me too. Quixel please react and solve the issue asap. We love your stuff you are the best, but we cannot work if the pipeline is broken. If it is a general issue or related to the launch in the next days, please fix it before. THANK YOU GUYS!!!

As Info. I updated the Metahumans as bundle working in the background from 5.3 to 5.4, may there went something wrong. I also activated the 2 factor verification.