My game does not launch

hello,I wanted to run a game under unrealengine when suddenly it shows me this LowLevelFatalError [File:Unkown] [Line: 258]
Direct3DDevice-> CreateComputeShader((void*)CodePtr, CodeSize,
nullptr, Shader->Resource.GetInitRefrence0) failed
with error E_INVALIDARG

can someone please help me

1 Like

is this issue has been resolved? i also have the same problem

1 Like

Greetings and thank you for posting.

I have found your error is also referenced in the documentation. This may be related to your GPU. GPU Crashes

I hope this assists you.

1 Like

Hah, that is odd.
CreateComputeShader file D3D11Shaders.cpp exists on line 258 in UE5 , not UE4, where it is line 356. This is not a GPU crash btw, I don’t see any solution in that UE5 documentation. Just another UE oddity.

*Since the line numbers match method names in the same files but different engine versions… that is probably a clue. are you migrating from A to B? somehow mixing them up? cache? It’s a guess.

*You should probably post more of the log, because there will be more info to trace.

1 Like

I can’t show the logs because it’s an error message and I can’t see the logs


my poppy playtime chapter 2 gives this error I will also send the error here: lowlevelfatalerror [file:unknown] [line: 258] 3ddevice-> createcomputeshader((void*)codeptr, codesize, nullptr, shader-> resourse.getlnitreference()) failed at d:/build/++ue4/sync/engine/source/runtime/windows/d3d11rhi/private/d3d11shaders. cpp:356 with error e_invalidarg

hi there, same problem here… please help

anyone find a way around this?


Is this solved? I have the same problem :frowning:

Hi! I had this error with Conrad Stevenson’s Paranormal PI and I fixed it like this:
Right-click on “the game” and “Properties”.
Under the General section, you’ll find out “Launch Options”.
Here just type -dx12 close this tab and run the game.
It worked for me.

1 Like

Здравствуйте, я решил эту проблему с помощью этого видео:КАК ИСПРАВИТЬ FATAL ERROR Line 258 ВО ВТОРОЙ ГЛАВЕ POPPY PLAYTIME? 4 НОВЫХ СПОСОБА УСТРАНЕНИЯ ОШИБКИ - YouTube первый способа и вот программа:Universal Unreal Engine 4 Unlocker - FRAMED. Screenshot Community
надеюсь помогу.

Hello, after almost a year in the case I want to contribute…

I am trying to play Truck World: Driving School but when I open it it opens “normally” and then the following appears:

The UE4-TWDS Game has crashed and will close

LowLevelFatalError [File:Unknown] [Line:684] pResource->Map[Subresource, pReadRange, reinterpreted_cast<void**>(&pData)) Failed at
d:\build\ ++ue4\sync\engine\source\runtime\d3d12rhi\private\D3D12RHIPrivate.h:1181
with error DXGI_ERROR_DEVICE_REMOVED with Reason:

My PC only has 1 hard drive (C:), I made my computer not slow, it was optimal for video games, I deleted the cache of my computer and Steam (where the game was purchased), uninstalled and returned to install the game, “solve” the “problems” with the game files, “repair” them and then try to run it before that alert appeared, but the game crashes anyway and I don’t know why it is due to an error of programming, to an internal error of the Unreal Engine, a game error, a game installation problem, or something that I, the user, did wrong and that is why the error appears, so how do we solve this conflict, why do I want to? play my game but I can’t deal with that problem

If there is any documentation or something that is helpful, tell me so that I can do something to progress on this error and be able to solve it.

i see lot of reactions from developers … seems t be easy bug about shader or typo … might be related to old videocards /// can just someone look into ? or you know just to ask for money every 2 min in games for every breathe