My foliage is looking so flat

hi foliage is looking so flat what can i do

Err… we’ll need a picture… :slight_smile:

I’m h aving a similar problem. When I paint the foliage, it comes out all flat and stretched, and this is with every foliage i’ve tried. Now it works perfectly in the default third person map when i was practicing, but it’s been happening in my own custom map. i’ve tried enabling/disabling nanites, no difference. both maps are part of the same project. I’ve included a pic to show the comparison. any ideas? i’ve got a feeling this is some kind of simple fix, but i’m stuck. only been using ue5 for a couple of weeks. I was talking to someone else and they suggested try disabling world position offset, but that didn’t make a diffeerence.

1 Like

From the look of it, it is WPO. Did you actually disconnect the pin in the material?

The other person I talked to mentioned the same thing. How do you actually go about finding that pin? And is it all the mats, because the particular tree I’m using has four.

It will be in the material for the leaves. It’s just called ‘world position offset’.

No difference. This is how the graph looks now.

1 Like

Ok, then it’s not that apparently :slight_smile:

What’s the difference between example map and the other?

Are you painting it or use landscape grass?

I’m using foliage paint mode on both. There doesn’t seem to be any difference in my foliage settings in either, but I still get the same result. The trees come out fine in both when I place them individually in selection mode but that’s really inefficient as I have to align them all properly one by one. I’m trying to identify if there’s any difference between the two levels, but I’m still learning to navigate the engine, so it’s tricky. One is the default third person map, and the other is a brand new level I created by adding new level in the content drawer and following this tutorial:
Tree bit is near the end. I wish I could just share my whole project or something, so someone could just properly look through it.

1 Like

Is the new level World Partition?

( I’m running out of ideas… )

Oh, what’s that?
Even if it turns out not to be the answer, it’s still valuable since it tells what isn’t the cause.

Which template did you use?


Empty level, I think. I just right clicked and hit create new level in the content drawer.

1 Like

If you zip your project, you can PM a link to it ( on google docs or something ).

If it’s large, then make a new empty project and migrate your broken level to that.

Wait, I can do that? OK, I’ll try that now.

1 Like