Download

My 4K Textures look very low Res in UE4, but were fine in UDK. Please Help!

Hey everyone! :slight_smile:

I’m having a little issue here that all my textured models in UE4 seem to be being rendered in game and in the Skeletal Mesh / Static Mesh viewers
with a texture resolution far below the actual resolution of the Textures.

I am using 4096 x 4096 textures on pretty much all my models (They may get scaled down later.) and when I view them in UDK / UE3 these assets look absolutely fine, very clear, sharp and high resolution. But when i view the same assets in UE4 using exactly the same 4k textures and the same models
they appear very low resolution, how I would imagine a 512 x 512 texture to look.

Here are some screens to show what I mean:

In UDK:


And now in UE4:

In UDK:


And now in UE4:

Both these models are using the exact same 4K Texture in both programs yet in UE4, they look really low quality.

Does anyone know why? And how I can fix it?

Seeing only really low res textures in UE4 is making it really hard to work on my materials. Please help. Thanks! :smiley:

I just imported a 4096 Texture and its looking fine. Can you please check the Texture settings?

&d=1408250518

What LOD group do you have the textures set at? I haven’t played around with it much in UE4, but I do notice that my textures start to LOD not even a few inches away from their location. You may need to play around with that and see what you can get.

Hey dudes. Thanks very much for your replies.

Okay so my settings are all default, including my LoD group which is “World” I havent changed anythiing. But i see now that on the texture settings panel at the top it says:

Imported: 4096x4096
Displayed: 1024x1024
Max in Game: 1024x1024

So I guess that’s the culprit here. Ive no idea how it got like that, pretty sure I didnt change anything. How do I change the “Displayed” and “Max In Game” to match the “Imported” 4096 resolution? Hope you can point me in the right direction. Thanks again! :slight_smile:

Okay I found a fix. I changed the LoD Settings to “Character” instead of “World” and now the Imported, Displayed, and Max in Game are all 4096 resolution!

Thanks for the help guys! :slight_smile:

Glad to see you resolved the issue. =)

weher can i find texture setting and how can i change it i have te same problem

i have foundt it but it only hase a 2k texture istead of 4k