Download

Multiple Particle System Depth Overlapping

I have a number of separate particle systems that intertwine that have issues with depth-sorting. The systems seem to “flick” between depths in what looks like a sort of Z-fighting, even though the individual particles are at separate depths.
I have the sort mode on all the systems set to “Distance to View.” Has anyone else experienced this or have any idea how I might fix it?

Here’s a Gfycat of the issue:

https://gfycat.com/SlipperySelfreliantGyrfalcon

Still no fix for this in the 4.6 Preview or any idea of how to resolve it. Anyone have any ideas?

share your material setup and the material settings.
Then show me your required tab module.

required.png
material.png

Setting the Blend Mode to Additive works for the most part in this particular case, but I’m wondering if there’s a way to avoid the sorting issues with the Blend Mode set to Translucent.

Thanks for your help! Let me know if there’s any other questions about my setup.